Teracube 2e review with /e/ 18q

Like @RazorTalon, I would like to share my experience.
In my case, I ordered a Teracube 2e last year via indiegogo and it was shipped with Teracube’s ROM.
I installed IMG-e-0.18-q-20210827132306-stable-2e a few days ago, following This documentation


  • The root procedure : officially authorized documented and supported, thanks Teracube !
  • The flashing documentation : Flashing a smartphone has never been easier, thanks /e/ !
  • No Google inside ! I was searching for a solution (device + ROM) for years
  • Nice interface / icons (even if I use KISS launcher as daily launcher)
  • Nextcloud integration : I was able to set my own server in the first boot wizard
  • (Almost) everything works out of the flash
  • Apps store : the best of both worlds (open source store + google store)


  • Bluetooth media bug: no media sound in Bluetooth devices since I plugged a jack headset
  • Camera application freeze and crash (with device reboot) sometimes
  • Camera focus: fails to focus on short distances (3-5 cm). During the focus, I can see it’s optically able to do it … but it never stops at the good moment)


  • Swype keyboard : I use swype feature a lot, but it’s disabled in the default keyboard. So I install AnySoft Keyboard, but it needs improvements to reach a level good enough for everyday use
  • I had to install Magisk + patch boot.img to make my banks applications to work. Not so negative, but this step may be useless if the phone wasn’t rooted
  • The robotic voice for alerts in Magic Earth. I tried it on another 2e with stock ROM and I don’t remember this ugly text-to-speech voice, I will try one more time later

Anyway, I’m very happy and very proud to use this smartphone with this ROM.
When these little cons will be fixed, it will be perfect !


Hi @gagan, I can see you are working on the bluetooth media bug here: Status · Boards · e · GitLab
In my case it works until I plugged a jack headset, and now calls works but media sounds (netflix, deezer, …) use speaker only.
Don’t hesitate to contact me if I can help to debug or make some tests.

To fix the robotic text to speech you can install the IVONA speech engine.

1 Like

Thanks a lot, it works fine !

Hi, could you please describe this process in more detail? I have a “Murena” (/e/ preinstalled) Teracube 2e, and I would really like to install Magisk. I am assuming that since you installed /e/ with the standard procedure, you are using the eRecovery, and used eRecovery to install Magisk? Which version of Magisk did you use, and what sequence of actions/commands in eRecovery and/or adb did you use? Thanks!

1 Like

Hi, I used this procedure : Installation | Magisk

But wait:
Before the last update, I disabled Magisk (as explained here : NOTE: Install to Inactive Slot is disabled in newer builds of the Magisk app due to changes that Google introduced to the OTA process: https://twitter.com/topjohnwu/status/1303574238796808192 | Magisk).
Then I installed the last update (0.19, 27 october) via OTA : without hands, it worked like a charm !
After the reboot, i tried my banks apps … and it works ! (except revolut, but I’m not sure why -it just crash immediately- and I won’t use it anymore)

So I don’t use Magisk anymore.

1 Like

The main remaining issues after v0.19 upgrade:

  1. the screen rotation to play videos in fullscreen (in web browser, newpipe and Netflix):
    After a reboot everything works immediately.
    But after few hours, if I want to play a video in fullscreen, the screen freeze but the sound still playing.
    Sometimes it works after 10 or 30 seconds, but sometimes I can’t do anything except reboot.

  2. Bluetooth audio interruptions when the moving the phone. Examples:

  • with my ear buds, I can listen music … but if the phone is in my pocket and I use my bike, there interruptions almost every time I move my leg down. Simple workaround: put it in my bag.
  • with my soundbar I can put the phone on a table few meters away (the distance is not the real problem), but there’s interruptions sometimes when I touch/move it (even few centimeters)

Otherwise, I can affirm this ROM is awesome and the Teracube make his job, it’s a good combination.
And I sure both issues are not a hardware problem so it can be fixed by software update.


thank you very much for the review and details regarding your steps in rooting your Teracube 2e with /e/. i am very new to the whole process so please accept my apologies in advance if i am missing something that you already addressed. however after reading the various pages and posts that you linked, i have a few basic questions:

  • do we need to follow the Teracube 2e specific root instructions to root the phone, or is there an /e/ specific root process e.g. use eRecovery to install Magisk and done? i could not find anything in the /e/ forum
  • is the 2e an A/B device?
  • did you also install TWRP or simply keep stock /e/ recovery?

once again thank you very much.