Teracube 2e stuck in bootload loop while flashing e

Hello, purchased teracube 2e directly from teracube and attempted to flash e. Using MAC, installed adb and followed instructions on how to install e on teracube. Went until:
4.Install /e/OS by typing the following commands in the console

fastboot -w
fastboot flash boot boot.img
fastboot flash recovery recovery.img
fastboot flash vbmeta vbmeta.img
fastboot flash vbmeta_system vbmeta_system.img
fastboot flash vbmeta_vendor vbmeta_vendor.img
fastboot reboot fastboot
And then after reboot phone went into the loop rebooting itself every 10 seconds or so with the message:
"Orange state
Your device has been unlocked and can’t be trusted.
Your device will boot in 5 seconds.”
Buttons on the phone seem do not work including power button. 

Any help would be appreciated to understand what went wrong and how to back on track.
Thank you

**[Regain your privacy! Adopt /e/ the unGoogled mobile OS and online services](https://e.foundation/)**![phone|80x80](upload://mtacZf1KIgDZJegjO3jnRNYJDPg.png)

With a Teracube I guess the first thing to clarify is that you are aware of the two models sharing the same name

Thanks. No, I am good. I checked serial number first and was working with the right file. In any case somehow I need to get out of this loop, not sure how.

Sure … First you want to try to get control of the device. You are familiar with the button presses for Bootloader and Recovery mode.

During the bootloop there is an instant where the device is OFF.

You want to try to catch that moment to try to trigger Recovery Mode with your button presses… try to see if this is available … from there you might be able to Factory reset (aim is to see if just First boot failed). At best this will lead to /e/ (not the previous Android instance!)

Try that first … then try to catch Bootloader mode /Fast boot mode.

It is reassuring if you can Force stop – then you can have a break, check that the device recharges ok. You should not continue till charge level is >70%

Yes, tried this to play with buttons in those OFF instances but same result. Same message would pop up whenever I do…

The Orange State message is nothing to worry about in itself. Devices vary, but some manufactures leave an ugly Orange state message others do it quietly – I suggest you leave that on one side and/or look it up later (it will continue after /e/ actually boots!)

You are probably aware that the bootloop happens because First boot failed. Internally, the device won’t boot to system, so it passes a message to “go back and try again”.

However in your position, you now know system will not boot … you now want one of the two other boot modes already mentioned.

Not sure what other boot modes you had in mind. Sorry for being a newbie in this but I think I tried different combinations of pressing buttons while is in OFF instance Power and volume down or up. Nothing worked out unless I am missing something here.

The two other bootable modes are

  • Recovery mode
  • Bootloader | Fastboot mode

Usually one finds the button presses on the “device info” page Info about Teracube Teracube 2e (2020) - 2e. I do not find them mentioned. Are you able to search for them in the Teracube forum?

There is a second issue – where I actually started from – the list of commands you quoted is not an exact match with the 2e install instructions Install /e/ on a Teracube Teracube 2e (2020) - “2e”

You are right. I just discovered that some how I mixed 2021 with 2020 S/N…adb commands that I made were wrong…OK, what happened is already happened…I cannot repeat this in a correct sequence anymore. How do I get out of this loop? Searched teracube forums and was nothing new. I followed these button presses already with no results. adb commands from the computer do not respond.

You just need to know for definite the button presses required for each Recovery and Fastboot.

Then you can interrupt the loop. (As previously said.)

Recovery: [ Troubleshooting ] Recovery Mode - Guides - Teracube Community
Fastboot | Bootloader: [Advanced] How to boot into bootloader - Guides - Teracube Community

Remembering you are starting from OFF only at that instant when the device is off!

It is not working. I saw teracube messages earlier and followed presses. I did this successfully before I started messing with the adb to go into fastboot mode. Not able to repeat this. Tried different times, sequences, take battery out and in and then presses etc, same results. Unless I am missing something here.

So we learn from above that Recovery mode Is reached from Bootloader. Reaching the bootloader is all you have to achieve!

With a removable battery are you able to reconnect the battery while

Press Vol+ and Power buttons simultaneously for 5/6 seconds.

I put the battery in while holding the above keys and there was no difference. Tried many times. Same result.

Would you say that it is the case that the physical buttons are having zero effect on the device?

Maybe someone else will chip in but maybe it would be a good idea to ask in the Teracube forum if you have really no reaction from the phone.

Your phone is in an unusual state due to the partial flashing you reported in the OP.

I will just point you to this link. This describes a much more intrusive way to flash these devices when all else fails. [Advanced] Installing factory Android image w/ SP Flash - Guides - Teracube Community.

SP Flash worked well. Got back in business. Thank you for your help.
There are some issues with e camera, some display settings, low volume even if it is set on max. Not impressed with the hardware and there might be bugs. Thanks again.

1 Like