Teracube 2e won't update or receive calls

I just received my Teracube 2e with /e/OS pre-installed. I can’t view videos in NewPipe, on websites, or in video messaging apps like Signal. I assume the recommended system update fixes this, based on other forum posts, but the Updater app won’t work.

I managed to download the update, but every time I tried to install it, Updater would close. I rebooted and tried over and over again. Eventually the Install button disappeared so I thought I’d delete the update and try to re-download. After deleting the update, it doesn’t show up when checking for updates, so I can’t even download it again.

In addition to this, everyone who calls me immediately gets my voicemail. I’ve done everything the same way I’ve always done when setting up a new phone with my carrier. I use my phone for work, so this is crucial.

Any ideas or suggestions?

Edit: The calling issue was rectified after my carrier’s customer support discovered the default Access Point Name in the system settings was incorrect. They provided me with the correct information to add a new one and now everything seems to be working fine on that front.

1 Like

You can install the update manually. After downloading the update, export it to a directory of your choice. Afterwards, turn off the smartphone. Now press the keys up + power until a menu appears on your phone. Choose an option like “Apply update” and select the previously exported update file. Now the update should work. When the update is installed, select an option like “Reboot into /e/OS” or something like that, if it doesn’t happen automatically. Now your smartphone should boot into /e/OS with the update installed.