Teracube stuck in recovery

Hello party people
I just got a teracube in the mail because i wanted to try out this os - used the easy installer on arch which worked perfectly - followed instructions, image downloaded and installed but after the install when the software says ‘you should see this logo while it boots up’ i just end up in recovery
I have tried several installs via arch, went and made 2 vms windows10 and ubuntu 20.04 respectevely and tried it via passthrough which didnt quite work since they got stuck at the rebooting to install stage
Any help would be appreciated, I’m not familiar with mobile os stuff at all

Small update:

Tried the manual install and i get the error ’

[r@archlinux Documents]$ fastboot flash recovery recovery.img
Sending ‘recovery’ (32768 KB) OKAY [ 0.784s]
Writing ‘recovery’ FAILED (remote: ‘This partition doesn’t exist’)

If after the easy-installer, you can boot to recovery that’s a good thing

1 Like

Alright, thanks

Now I’ve run into an a bit funnier issue

After the failed manual install it’s caught in a bootloop
If i just start it it keeps trying to boot over and over until its dead and if i try power+vol up which i think was the loader i get a permanent blackscreen
It isn’t detected by the easy installer and i cant do anything via terminal either

Hi @konsos I don’t know if you have searched the forum for teracube + easy-installer but there are two of you in what looks from here a similar position. Please compare with Installation stuck in recovery mode after easy-installation.

Teracube has quite recently returned to the Easy Installer list, having been removed at least partly due to too many failures.

I had a Super partition device once which I liberated to /e/; I remember now that one thing I found worked was to flash the device in one go. Of course Easy Installer aims to do just that as do the manual instructions https://doc.e.foundation/devices/emerald/install.

The reason I mention this is that if the Teracube is similar, any breakdown in the Easy Installer flow could be very hard to know or advise how to get out of.

You say your Teracube just arrived, so I have assumed it is the newer “2021” model. Please can you confirm that we are all talking about the same device. :slight_smile:

Caution: Before moving forward, ensure your device is a Teracube 2e (2021). Please look at the serial number under the battery or dial *#06#. If the serial number starts with 2021 (ex: 202111T2Exxxxxx), you are at the right place!

I an not going to suggest anything experimental, but please try reading as much as you can. Previous answers, linked indirectly from my first link above might give you an insight. (I do not want to highlight any one case as I cannot tell if you all have some significant thing in common and I don’t want to misdirect.)

If you decide on a fresh start you have the option to flash the “Factory” ROM with a powerful tool (SP Flash) which needs Windows. Beware it is especially powerful, please read the guide carefully.


Note also the “Update: new process” linked in the first lines.


Thanks for your reply.

My issue was originally that, but by now I’ve managed to completely nuke it with my attempt at the manual install. I don’t get any output - all I can achieve is the initial bootscreen with ‘Teracube’ and the logo, or when I press power+vol up I get a completely black screen. It’s also never picked up as usb device - the only proof that it’s connected is in devices/usb connections where it just says ‘Android’.
I tried to run some adb commands, but they did nothing either and not even that lists it as device.

The model is correct, I already checked that when the first install ended in recovery.

The only ‘breakdown’ during the install was afaik that it didn’t pick up on permission before the actual install and I had to click it twice.

The Factory ROM flash also didn’t work since it’s not picked up as a usable USB device anymore and pass through to my w10 vm was therefore useless.

I’m lost.

Just tried plugging it in and it’s stuck in a reboot loop.


and this is the blackscreen after power+volup
(during blackscreen its not seen as usb at all)


Under no circumstances do any more with platfom-tools. I now wish I had worded my first post more strongly. I think you are now in the position many were in about a year ago, please check some of the older posts (many then were for the 2020 model) for other user experience.

If SP Fash does not start to work exactly as the manual, you should not continue with that either.

Please consider to Report an issue

I recommend you ask on the Teracube Community forum. Did you use the “new process”?

Whichever, please ask on the appropriate thread. I am expect that the reply will be to return it for a re-flash, but they will know the right way to advise you now. I don’t know what the warranty situation is at all.

Don’t worry, your post had nothing to do with it. I just played around when I got it, gave up and wanted to try again now, but that’s what happened. My fault for not waiting for a response and just trying to wing it.

Yea, I thought about going to a repair shop tomorrow, or do I HAVE to send it back?
Thought since it’s just stock android 11 I believe there should be an easier way than sending it halfway across the world

I mean I’m no expert when it comes to warranty, but I doubt that just playing with software to a degree that doesn’t harm the hardware voids it.

I don’t know about a ‘new process’. I’m new to this and just went with the first option that I found which was on the /e/ site first with the easy installer and then I went to documentation searched for teracube2e and went with the manual install

Here I was referring to the Teracube community, see Post #4

Reviewing my input so far, the evidence starting from

"Writing ‘recovery’ FAILED (remote: ‘This partition doesn’t exist’)

points to the device being soft bricked. I did not say strongly enough I would not now use platform tools. I merely linked perhaps too much reading material for you to try to deduce your own way forward with people is the same position of Teracube + Easy Installer + stopped mid process.

I suggested try with Easy Installer only. this was based on the possibility that Easy Installer could pick with adb but would drop the job and not experiment with irregular adb commands, and you would have by then read how to collect the log in the linked post

Please compare with Installation stuck in recovery mode after easy-installation

… because it links to Teracube stuck in bootloader while flashing easy installer and thence Howto troubleshoot issues with the easy-installer with a potential solution. Again I cannot tell if this is your problem from what you say.

Perhaps too indirect but I do not know the answer. My experience with a Super partition device is that stopping the install flow mid stage causes “Partition does not exist”.

With this newly “American designed” phone there is very little other back story and I see no mentions of the standard way to fix qualcomm issues with their especially designed flashing proposal. Speculation, maybe like Motorola they do not want to release the method and support it free of charge.

Hence my suggestion to read the Teracube proposal – top of this post.

Alllllright party people, I think I cracked the code

I installed w10 on an actual machine the factory reset worked like a charm
Retried the install got to e recovery took the guide that was posted and did the deed
after about 2 hours of trying the sd and adb methods i rechecked absolutely e v e r y t h i n g
and as it turns out there are 2 ‘teracube 2e’
Now, as I was told basically only the 2021 version works, which it is
What wasn’t as obvious was that there’s 2 2e’s
The 2021 version that works with this os is ‘2e emerald’
I have the baseline ‘2e’
Only the 2020 version of that phone is appearently approved

That is mildly infuriating

(Quoting my first contribution to this thread.)

For others reading this, only the newer Teracube emerald is supported by Easy Installer.

Yea and in terms of serial number the only difference is that there are 3 ‘1’ after 2021
so the correct phone is ‘2021 1 1 T2Exxxx’
and the one i bought is ‘2021 1 1 1 T2Exxxx’

1 Like

I had the same problem but after flashing vbmeta ( unofficialtwrp twrp-3-5-2-root-teracube-2e/) and unplug usb cable and a couple of power+volumeUp and power+volumedown I get a working e phone :wink:

I wonder if you have asked in the Teracube forum to see what is the significance of this detail in this use case?


I note you say

I have the baseline ‘2e’

I feel it would be worth trying to have this verified. A well worded question leaving it open that you are really inquiring about the significance of the “3 ‘1’ after 2021” might get the attention of @sharad there.

I haven’t asked about that, only stated that the /e/ install went wrong and how I can fix it

My source for that is from the e install but I can’t recall where exactly it was
Somewhere there’s specified which phones exactly work and for emerald it’s the 2021 version and for the baseline 2e only the 2020 version was specified

When I read [Important Read] Difference between the 2nd batch VS 1st batch of Teracube 2e - Teracube 2e - Teracube Community

I see 2 variants, (very confusingly 1st batch, 2nd batch; 2e and 2e-emerald) I do not see a third variant where to “3 ‘1’ after 2021” is the significant feature.

If you contemplate their reply [Teracube 2e] Instructions to Install Factory Software and to Reset - Guides - Teracube Community be aware that you will use the powerful SPFlash process, so it would be only wise, to read all the instructions very carefully and question anything which makes you doubt your situation.

I already did the factory reset.

Maybe they added the additional one because they for some reason produced the 2020 version again in 2021 and had to differentiate between emerald and the previous one

So did you reset with 1st batch or 2nd batch image, at Teracube?

  • Smartphone Selector shows 2 devices first line “Teracube 2e” – does hover on this give the result you expect?
    second line defines “2e” or “emerald” – can you reword your position about which device you have?

We know that Easy Installer Try the Easy Installer beta only supports

Here I am only really trying to get to the bottom of the idea that you might have a “third variant”!

I used this

The serial number on the list is from the 2020 version ‘202011’ I have 2021111’
As I stated earlier - I probably do have the old version, only produced in 2021.
That link was actually the thing i was referring to earlier.

“My source for that is from the e install but I can’t recall where exactly it was
Somewhere there’s specified which phones exactly work and for emerald it’s the 2021 version and for the baseline 2e only the 2020 version was specified”

I tried both the easy installer and manual install, which failed.

I would be inclined to record that observation here /e/ OS installation for Teracube 2e (both batches) - Guides - Teracube Community.