Text and Incoming calls not working outside active call

My USA formatted S9 is having issues with text and incoming calls. I actually did some testing and found that the phone only sends/receives text messages and receives incoming calls when I place a call and the call is active. Otherwise texts fail, and incoming calls do not ring through, There is silence on the line from the phone I am calling my e/ phone from for the period of time a ring should be audible. The calls do go to voicemail correctly and can be listened to etc.

For example, I called my colleague and when speaking with him on an active call, I sent him a text and it was received. During the call I received a text response, and replied again with no problem. I also received an incoming call during the time I was on with my colleague and I was able to answer the second call normally. Once I disconnected and call was inactive, the phone no longer functioned as though it disconnected from the network without an active call keeping it connected. Does this make sense?

I spoke with the service provider multiple times, reset the Wifi, mobile and bluetooth and in addition, attempted to set the APN settings. Unfortunately the phone does not allow the APN to be changed. The message on screen is: “Access Point Name settings are not available for this user”. I also removed the SIM card and restarted the phone with no change to the issue.

So at this point I have a phone that is for the most part non-functioning unless I am actively calling another cell number.

I am in the US and currently on T-Mobile towers. The provider, Patriot Mobile, is sending another SIM card that will connect to ATT towers but I am not confident this will rectify the issue. In the meantime I need to perhaps restart my ATT phone but needless to say that’s not what I prefer.

Any assistance in updating to allow the APN to be manually set would be much appreciated.

Thanks to all for reading and any help would be great.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hey bud, I’m a US user too. Did you get a resolution on this? I’ve been having a similar issue on Mint Mobile but it does not seem to be as extreme as you

Hello, I did get a resolution, and unforutnately it was initially to reconnect service via AT&T, and then once I found service at my residence was poor, to change to T-Mobile. I would have liked to continue with an independent provider such as Patriot Mobile, but their network simply didn’t play well with the e.foundation operating system. Please see updates to my thread here, and let me know if you have success! Take care and best of luck…


Thank you.

Odd. Clicking your thread says it’s a private thread or doesn’t exist.
Anyway, sorry you couldn’t stay with Patriot. I’m using Mint, which uses T-Mobile’s towers as I understand it, which has good coverage at my house, but yesterday I had another instance of a missed call and delayed text. Bout to hop on the tech support line and find out if they have any additional suggestions, as well as report this to my other existing threads.
Hopefully soon there will be an easy upgrade path from 8 to 10 and this problem will be moot.

EDIT: https://www.reddit.com/r/mintmobile/comments/9fdaok/not_receiving_calls_and_delayed_sms_status_update/
This is actually quite an accurate description of the problem

ANOTHER EDIT: I’ve found a setting in Developer Setting’s that keeps the phone connected to data even on WiFi. Perhaps I can enable that as a workaround for now.

Do you guys have voLTE enabled when using T-mobile or T-mobile MVNOs? If not, your connection drops to 3G for calls, and if 3G coverage in your area(s) is weak, then that will cause problems for calls and texts. Shouldn’t be an issue with AT&T/MVNOs on AT&T, at least 2022.

(Apologies if this is totally unrelated to your situation or phone.)

I have no idea how to enable VoLTE. To my knowledge it isn’t working yet.
If it’s possible to get it working I’d love some instruction. I actually believe this could solve the problem.

On the current order page for /e/ devices for the U.S., they state that VoLTE isn’t working yet. Maybe an update will be forthcoming.

In general, though, if a manufacturer has certified their devices for VoLTE with one (or more) of the major networks, the toggle to enable it will appear in your Network settings when you have that carrier’s SIM card inserted.

If feasible, you might want to consider switching to an AT&T MVNO, or AT&T itself, temporarily, if they have good coverage in your area. They’re still working fine for phones without VoLTE, because their 3G network still functions well for calls, whereas T-mobile’s might not, if they have started retiring 3G in your area(s).

Voice over LTE (VoLTE) only works over 4G data.

P.S. AT&T will be shutting down their 3G network, too, sometime next year.

Mint shows up as an unknown SIM card, and I don’t see any toggle in Network Settings to get it working. I can enable it from the Mint Mobile app, but I’m not sure if that actually does anything.

Check your IMEI with T-mobile’s compatibility checker: Bring Your Own Unlocked Phone | IMEI Compatibiliy Check | T-Mobile

Your IMEI can be found under About phone or whatever it’s called on Samsungs.

I’m not sure what Mint Mobile’s app does, either.

Enabling VoLTE on Samsungs: How to enable VoLTE on a Samsung Galaxy phone | Android Central
(But it won’t be present in your settings, if the particular device wasn’t certified for T-mobile’s network by Samsung.)

Also, to test whether VoLTE is enabled, make a call and watch the LTE indicator in your notifications area. (It would probably display VoLTE instead if it’s enabled on the phone.) If it disappears, your phone is dropping to 3G to attempt the connection. (A problem if there is no, or weak, 3G.)

Odd. Mint says not compatible. T-Mobile says it is.
The device was purchased from eSolutions so probably not made for T-Mobile by Samsung.

It probably depends on where /e/ acquired the phone from. Europe firmware? N. America firmware? Global? You could ask /e/ Support about that, but if the IMEI is approved by the carrier, you should be good to go: https://en.wikipedia.org/wiki/International_Mobile_Equipment_Identity#Structure_of_the_IMEI_and_IMEISV_(IMEI_software_version)

I’m not sure why Mint Mobile would disallow it if T-mobile does allow it. Maybe Mint is afraid their coverage for your address isn’t as strong as T-mobile’s…I’m just guessing, though.

Edit: Good news is on the horizon: