The galery app doesn't show my photo's from OpenCamera any more

Since a couple of days my gallery app doesn’t show the pictures I take anymore. I haven’t changed the destination of the photos. They are stored in the internal memory DCIM/OpenCamera. I can see them when I look at the location in question. I also use the gallery to edit them etc. That does not work now.
Does anyone have an idea?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone


Perhaps a reboot, first. Then have a look at Settings > Apps for both OpenCamera and Gallery (permissions) and Settings > Storage because almost full storage creates bugs…

Hi, I checked both the settings for Apps and Storage. Even after a reboot everything reamains the same.

Try to go into Settings > Apps & notifications > Gallery > Storage > Clear data.
This won’t delete any photo/video.

I have tried all suggestions, without result.
Surprisingly for me, if you select ‘clear data’, all the photos will remain.

What happens when you try to open the picture through Files ?

Does other gallery apps work ?

No problem when I open the pictures through files, but then I’ve no opportunity to edit the picture.
So the photos taken are not ‘gone’.

Try to change the path of your pictures/videos. I personnally have Pictures/OpenCamera.

You also have to change the destination of photos/videos you take with Camera (in Camera settings).

Hi, I’m a bit confused now, but that seems to work. Thanks.

1 Like

In my case it’s different: I can’t see taken Camera pictures when they should be stored on the external SD card.

When I configure Open Camera to store the pictures on the device memory I see them immediately in the Galery, all as expected. When they should be stored on the SD card every other app shows these pictures where they are but they don’t appear in the Galery.

This is interesting because normally the Galery app does indeed show pictures on the SD card I copied there from another source, it just can’t show just taken Camera pictures. What’s wrong with them?

I ran into this problem a while ago. Stored to internal memory, pictures only show up after a reboot in gallery.
Changed gallery to simple gallery pro (from f-droid), which works perfect.

1 Like

Ah, great, that’s much better! Now I can also hide some folders (music stuff with album covers …) Thanks a lot.