The Privacy Dad's blog post on using /e/OS as a beginner

I’m a long time user of /e/OS and have written a post on my The Privacy Dad blog about my experiences with /e/OS and how one of my teenage children now uses an /e/OS device. I hope you’ll find it relevant to this section of the forum: De-Googling Your Smartphone (as a beginner) | Welcome to The Privacy Dad's Blog!
TPD

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

8 Likes

“If you are someone averse to tinkering with IT devices, I would recommend just buying a Murena phone (world) or a FairPhone (EU only). Both have /e/OS pre-installed.”

This makes it sound as if Fairphone (with a non-capital p) ship their phones with /e/OS. They do not, Fairphones by default come with Fairphone OS, a “normal” stock Android OS with Google Apps and services.
Fairphones preinstalled with /e/OS come from the e foundation/ Murena, clarity about this might be important for potential buyers.

Buying “a Murena Fairphone” (as they are branded in the Murena shop) should do the trick :wink: .


“/e/OS is a ‘fork’ of LineageOS, a de-Googled version of the Android operating system.”

LineageOS doesn’t come with Google Apps and services installed, which of course can be seen as a selling point of it, but LineageOS couldn’t include those Apps and services in a legal fashion anyway. Users can easily add the genuine Google Apps and services themselves with the help of Open GApps and similar projects.
LineageOS isn’t actively degoogled, it’s not the focus of it or why it exists.

If anything, /e/OS is a degoogled fork of LineageOS, see /e/OS product description - a pro-privacy mobile operating system and cloud services and the link to the deGooglisation white paper given there.

5 Likes

Thanks! I appreciate you taking the time to give this feedback. I’ll make the changes tomorrow.

For the blog, I have a list of how all the different brands capitalise their names - it’s random and crazy :). I missed this one.

As for the second point, what would be an accurate way to describe LineageOS then, in layman’s terms?

1 Like

I forgot:

“(EU only)”

Since it’s complicated … https://support.fairphone.com/hc/en-us/articles/202005103-Shipping-countries-for-Fairphone-products-Europe-only- (and the Murena shop seems to apply this, too, but I only tried for UK, Norway and Switzerland as test cases) … a simplified term makes sense, but I guess “Europe only” would be a better approximation.

I’ll just leave this here …

(Source)


I would say LineageOS is a community fork of the Open Source Android base (called AOSP) primarily (not exclusively) aimed at devices which don’t get supported with recent security patches by their vendors anymore.

LineageOS themselves would simply say … *“A free and open-source operating system for various devices, based on the Android mobile platform.”*

1 Like

Thanks, this is helpful for me for sure. I will probably go with the second definition, given my target audience :slight_smile:

That Europe chart is crazy!

Thanks again for reading and your constructive feedback. I really appreciate things like this.

@AnotherElk I’ve made the changes and posted a little edit thanking you (anonymously). I’d wanted to add your username, but thought I’d better check with you first.

Edit: after publishing this article and sharing it on the e Foundation forum, I received detailed and constructive feedback from one of the people on there. It just further illustrates the positive approach within that community.

1 Like

Staying anonymous in the context is fine, focusing the credit on the community is fine :+1: .

3 Likes

@theprivacydad
I don’t understand how one can “degoogle” by depending on microG and Aurora Store (or any other Play frontend).

(In addition to microG directly phoning home to Google (checkin/GCM) and downloading proprietary code from Google (SafetyNet), it does not remove/address the proprietary Google library that all apps use to communicate with it.)

Noting my bias, please consider taking into consideration other aspects of the system that I’ve detailed here: https://divestos.org/misc/e.txt

See also my broader overview here: Patch Levels - DivestOS Mobile

While Android was based on Linux software

Android is Linux, plain and simple.

@SkewedZeppelin

Thanks for reading and the feedback.

I think the points you raise are good but too nuanced for my target audience, which is people taking first steps. I suppose what I mean is tying all purchases to a specific Google account that you might also use for Chrome searches, Google Drive, mail, login in on websites, etc… It’s a good first step to stop using such an account.

Realistically, people won’t go this route if it means giving up all the apps they are used to. I think it might be too big a step for most.

I will check out the links you shared, thanks again.

1 Like

A simple, easily digestible write-up for the uninitiated. :+1:
You might consider calling attention to the “white paper” (PDF) link on this page in the “DeGoogling” section, which highlights some of the additional steps taken by e-foundation.

1 Like

Thanks, that’s what I am aiming for.
I’ll look at that link and maybe add it to the Documents section.
Thanks again!

1 Like

By the way: not sure who runs the site, but the DeGoogling link at the top of that page gives me a warning about not redirecting properly. I did find the white paper by scrolling down.

1 Like

Can you give a screenshot?

I don’t get any such warning either way.

True, but in standard LineageOS, (i.e. without installing GApps) there are very few links to Google servers, so it is considerably less "Googled** than stock Android.

And with LineageOS for Microg you have something which is nearly as “de-Googled” as /e/OS, and which, like /e/OS, allows many apps which rely on Google’s APIs to run properly. It also doesn’t have /e/'s Advanced Privacy or App Lounge, which you may see as a plus or a minus, depending on your point of view :wink:

1 Like

Screenshot from 2022-11-27 13-30-25

It’s the above link “DeGoogling/UnGoogling in /e/OS” that leads to an error for me.

Could it be uBlock Origin?

Tried several browsers, only Iceraven had that quirk. Also in private mode where uBlock isn’t used.
Kiwi has uBlock but it didn’t have that behavior either. Maybe it’s a *fox thing. Oh, happens in Mull also.
Minor thing.

I don’t have that in Fennec on the phone and Firefox on the desktop.

Turning uBlock off didn’t change the error.

1 Like

Quick check with clean installs of Mull, Fennec (both v107) and Firefox Beta v106. Behavior exists with Mull but not with Fennec or Firefox. Maybe extra patches included with Mull and Iceraven come into play.

1 Like