The Web - What It Used To Be And What It's Become

Quite sure that for some who have been around long enough, they’ll be in agreement with most of what’s written.

Against Modern Browsers -


Maybe it fits here: I leaned about which is a protocol + markup files to create a minimalistic, text-driven web.

Haven’t explored it that much so far but installed on desktop and on my smartphone to try it out.

Mobile browsing on the phone is amazingly fast and the APK is only 2.4 MiB :smiley:

1 Like

Yep. I have Ariana and Deedum on the phones.
Recently found out that one of my main sources for microG and NoGApps packages, Shadow53, moved over to Gemini.
You may have seen DistroTube’s videos about that protocol.

I just wish the Gemini site index had at least some kind of description for the URLs.

Oh, this old thread.

Project Gemini: Relive simpler web/gopher days

1 Like

This is some interesting stuff! I’ll definitely have to look into the Gemini protocol and DistroTube’s videos. A big fan of minimalist software.


We could just collectively decide to use an old browser, an old opera or Netscape maybe, and if their site doesn’t work with it, it just sucks to be them. We’ll take our business elsewhere. We have to vote with our wallets.

1 Like

Started to checking this out, but today Ariane shows just

Bad response: Server error:
Handshake failed”

Anyone else with similar problem?

Sorry but you don’t mention what you were checking. No link provided.

Sorry, I must have forgotten this isn’t just gemini thread. But I can’t basicly access any gemini site, like example




Here is a way in to Gemini. ÖLAB
and an https.


Interesting. I may have found out what the deal is. Maybe.
Using the “Open In Ariane” function in the selection menu on the URLs you posted.
The first one does indeed produce the error you showed earlier. The other two opened fine but somewhat oddly.

Doing some testing, it seems it’s all about the trailing slash, at least for the main Ariane page. Put the URLs in a text editor then tried to open them. The Ariane page fails without the slash but loads fine with.

The other two sites seem to load with or without but more often than not the main Ariane page will appear. Hit the back button and I get the site I opened.
It’s always been recommended to add trailing slash to URLs, maybe that also applies to Gemini.
I guess there’s a bug or two that needs ironing out(?).

I tried those sites just now and they work for me in Ariane 2.4.0.

Edit: hadn’t seen marcdw’s response earlier, I can confirm what he writes: the first link doesn’t work without trailing slash, the other two do.

1 Like

Don’t know what happened, but even aftee clicking that link and from page open at gemini, it just doesn’t work. Also if Ariane asks do I want to search with GUS instead,clicking ok and same error again.

Edit: Removed cache and data from Ariane and everything works again. Thanks for tip about trailing slash and all the help for you all.


I headed over to Ariane’s Codeberg site. There’s an open issue regarding a similar handshake error.

The behavior I mentioned where I opened the other sites but Ariane would display its main page instead is also known.

Word has it a version 3 is on the horizon that may address one or more of these issues.


By the by, has anyone checked out Xenia? Easily browse Gemini using your default browser. Just noticed bookmarks are a part of the proxy/app.

Xenia (Browse Gemini sites using a normal web browser)

Privacy Browser on gemini…

1 Like

Would you mind checking this link and correcting if possible? It reverts me to the /e/ forum homepage. Thanks for what you share @marcdw .

Edit: NM, I found it.

Excuse my tardiness. Oh my, I should’ve double checked the link before submitting.
Oddly, when I tried to copy/paste the correct URL it put the main community URL instead again. Maybe my fumbling fingers.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.