Threema won"t register for push notifications after update


After updating my Fairphone 3 to /e/OS 0.11, I cannot get any push notifications for Threema. I only see new messages if I open the app.

In the microG settings, Threema was listed but it said “last notification 4 days ago”. So I set “Allow registration” for Threema to false and then to True again, hoping it would re-register. However, since then it says Threema is not registered for push notifications.

I also tried turning GCM off and on again, did another checkin, renewed Threema’s push token, and restarted my phone. Nothing. It says GCM connected and Threema not registered.

I use Threema as my main messenger and really need the notifications. Is there anything else I can do?


If you do this you have to uninstall and install the app again.

What is the “Current state:” of Google Cloud Messaging ? Connected or Disconnected ? (when you are connected to the internet)

In this case, it would be really good to show a warning upon turning the switch, explaining a reinstall will be needed to turn it on again, and asking whether this is intended.

In fact, I did now reinstall Threema and it works again.

Actually it does when you click on “Unregister”. But it doesn’t if you disable “Allow registration” (which is a useless thing to do if the app is already registered) and choose “OK” to unregister it instead of “CANCEL”.

I see! Let me explain my misunderstanding then, maybe it can help to improve the UI.

First of all, I did not get that “Unregister” is actually a button you can tap. I thought it was merely text, as there is no switch.

Therefore, I disabled the switch in “Allow registration”, then I was asked if I also wanted to unregister. I said yes and it was unregistered - in this case without the warn message.

If push notifcations fail, you can switch to “polling” mode.

In Threema open “Settings” > “About Threema” > “Troubleshooting” > “Workarounds” and activate “Polling”.