Tracker Control Crashing in Shelter

Hi guys,

I installed tracker control within shelter, along with couple apps that I need to use for whatever reason that contain trackers.

Now, when I unfreeze and launch tracker control within shelter, very rarely it works properly. I get a following notification after launching it:
Screenshot_20210105-134839_TrackerControl

Usually, besides Tracker Control, I have microG an SystemTracing running along with Files and Aurora Store, all other apps are frozen. If I freeze the apps above though, and try to launch just the tracker control app, the same error occurs. Anybody came across the same problem and knows how to resolve it? Or is it something that happens because of /e/ operating system and should be shared with @support?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

freezing TC makes absolute no sense. TC MUST run in the background to block unwanted background calls.

TCs impact on battery is very low, especially if you freeze all the apps with trackers, when they are not in use. I just let it run all the time.

Hi!

You misunderstood me. I’m not freezing Tracker Control - it’s kept unfrozen in the shelter. I’m keeping it in shelter with all the apps that are containing some trackers to prevent data leakage. But when I unfreeze those apps in shelter, tracker control sends me this error notification - which means tracker control isn’t functioning properly while in shelter.

Is there a way to solve it? Or should I just keep tracker control out of the shelter environment?

as I have written, best your a joining the telegram group. The dev of TC is very helpfull

I just have made a test. As you can see in the ss, I have frozen all apps in shelter. I never have gotten your error message. I think it’s in issue of one of your apps your a freezing ins shelter. I would prefer freeze app by app with a stop between. So that you can see at which app the error is created.
freeze

Thanks! I will test it out and see what makes this app crash. I don’t want to have tracker control outside of shelter, since I’m not using any tracking apps in my main phone profile.

I checked and same error notification occurs even if I unfreeze and use only tracker control in Shelter, with all other apps frozen.

than it’s a bug in eOS

I will try to actualize the system and see if the issue persists. I’m using fairphone 3+. Maybe it’s device specific?

I installed newer version of the /e/ OS but the same thing happens. Tracker Control works properly in main profile and crashes in Shelter - with the same error as above.

From privacy standpoint - should I move those tracking apps (InPost, HabitShare) to main profile so they can be properly blocked by Tracker Control, or is it better to keep them in shelter?

I got a response from Tracker Control developer (I messaged him directly) and he said it has to be an issue of the TC app interacting with shelter incorrectly and he doesn’t know how to help me. But some others with eOS seem to have it working OK in shelter, so is it phone specific?

I also have a Fairphone 3+ and TC is running fine for me in shelter.
Are you on dev or stable channel?

which TC version are you both using ?

I have just installed. I can start both apps and TC find a lot of trackers. I fear the won’t work with blocking trackers. I would try using access via browser

@NoName161

The apps I mentioned work fine without trackers, while blocked with TC. I managed to get them running at least, before the errors started to occur in TC. Unfortunately I need to use both of those apps for my work.

@ljahn

I’m on stable channel.

Hi!

After fiddling with TC a bit in my home profile, I turned the private DNS OFF in internet settings and now it works properly - both in main profile and in work profile under shelter.

1 Like

thanks for bringing this up, just installed it, and WOW! did I ever apprecaiate being able to block all of the Cameras, Calculator, old Telco apps I had forgotten about ( uninstalled )… a great program.

1 Like

When you installing TC it reminding you on bottom if screen NOT using private DNS.

Strangely enough it does that only in the main profile - not in shelter. At least I didn’t see that notification in shelter and I had it only installed there at first.