Trouble updating Moto G 'Osprey' to /e/OS 0.18, released August 14 2021

I put off updating my Moto G ‘Osprey’ since last month because I was afraid my old Moto wouldn’t be supported. Additionally, I’m still scarred from my previous Samsung bricking after I tried updating it’s /e/OS earlier this year.

Anyways, I finally came around, and tried updating my Moto G Osprey. After installing the update, I attempted to install the update. My screen first shows a loading bar indicating the OS is installing. When the bar is at like 50%, the screen switches off. Then when I hit the power button, i get ‘bootloader is unlocked’, and then the dead android guy with ‘no command’ written underneath his sad corpse. I am perplexed. Is this because /e/ hasn’t created an updated OS for my particular model? This is honestly getting so tiring.

Appreciate any help or insights.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

You may have to replace TWRP by e-recovery before update to 0.18

Im not sure what that means. I already have TWRP downloaded on the phone. Is there a new version of TWRP I have to download? Thanks

according to dev,
TWRP may be actually no more capable to run OTA updates.
you need to install the e-recovery instead.
you simply can use the TWRP install feature to do that
( download it to your SDcard or internal storage before ),
but for the inverse, you need Odin/Heimdall

Thanks for this. How do I install e-recovery? I dont know what the TWRP install feature is. Thanks