Trouble uploading contacts vcf file to new teracube phone

I am having trouble populating my contacts list. I have a teracube with the /e/ operating system. I have downloaded my (188) contacts to a vcf file, and seem to have uploaded it to the phone. But I cannot get the contacts list to populate with the entries.


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

What exactly have you tried? What does “uploaded to the phone” mean?

Contacts has an import option. Have you tried that?

Here’s a really ancient import tool. No idea if it works.

Import Contacts | F-Droid - Free and Open Source Android App Repository

I have tried the import option of the phone multiple times with no success.

I also exported the contacts to a vcf file from my old android phone, which I can see on the new phone; but it is in the file folder. I don’t see a way to have the vcf populate the actal contact app.

I have tried transferring via close proximity Bluetooth, also via two USB cables and a computer. Everything fails.

I wil try the fdroid app.

Any other ideas are appreciated.

Linda Hayman

Mar 28, 2023, 7:29 AM by

I searched the forum for “contacts import vcf” and there are quite the number of threads related to your situation. Might have to go through some of them.
Here’s one from awhile back.

Do you have an /e/ account? If so you can probably import the vcf online. Last I read, it should work.

I set up an account, but activity is limited for new users. I will see if I can do a search for some help.

Thank you for your reply,

Linda Hayman

Mar 28, 2023, 8:35 AM by