Troubles installing /e/OS on a Edge 20 Pro

Hi, I have problems with OEM unlocking on my Edge 20 Pro.
I can’t unlock it neither in the Developer options in Settings nor from Linux with the terminal (see attached image).
I have Android11, do I need to upgrade to A12?

It appears that you need an unlock code from Motorola.

Thanks, I found how to get this code (which voids the warranty) but despite following the official Motorola guide I was unable to enable the OEM unlock.
Anyway, do you know if I need to keep Android11 ​​to install /e/OS or can I upgrade to Android12? Maybe with A12 I can unlock it, I don’t know…

… For sure.

Would you like to share where in the process it fails ? Perhaps starting from

  1. Once the device is in fastboot mode, verify your PC finds it by typing:
 fastboot devices
  1. Now type the following command to get the bootloader status:
 fastboot oem get_unlock_data
  1. Follow the instructions at Motorola Support to unlock your bootloader.

  2. Since the device resets completely, you will need to re-enable USB debugging to continue.

You should expect to upgrade to Android 12, S before installing /e/OS at Android 12:

One more point

Models Supported
Other models are not supported

My model is XT2153-1.
I followed the guide but when I give the command “fastboot oem unlock UNIQUE_KEY” (replacing UNIQUE_KEY with the 20-character code received by email from Motorola) the terminal sends me this:
Then I reboot but the OEM unlock toggle in Developer options can’t be enabled.

On my devices (from Sony not Motorola) I had to add the characters 0x before the 20 character unique key. Might be worth a try

Thank you pete I tried but don’t work

Just a thought … `remote’ is seen in the “fail message” …you have a SIM installed ?

I tried several times with and without SIM, but it doesn’t work. In Developer options under the OEM unlock toggle it says “Connect to the internet or contact your operator” as if it had no connection, although I have both the SIM and WiFi.

I have read that some models sold by some operators cannot be unlocked.
I bought the phone without a SIM and without a subscription so I don’t understand why it should be.
I contacted Motorola support indicating the IMEI code of my phone, let’s see what they say.

I found.
All it took was restoring the phone with the Rescue and Smart Assistant software to the latest version. Then the OEM unlock toggle can be enabled.

I found a problem: the screen flickers regularly when there is a black background, for example in Settings with Dark mode activated. Do you know how to solve?

I have exactly the same issue with a Edge 30. The Rescue an smart assistant is certainly very smart, but I don’t have access to a Window system…
Do you know another way to do the same thing without RSA??

I installed the e/os system on the Motorola Edge 20 Pro model XT2153-1 and following the instructions indicated I performed the to unlock bootloader on the Motorola support site. Everything was quite smooth. The software version is Android 12. Do you know when there will be an update? It all works very well.

Referring to the ROM download page of this device e-1.20-t is published but it will be a manual upgrade to Android 13 (T).

(OTA upgrades only happen for stable builds.)

This topic was automatically closed after 61 days. New replies are no longer allowed.