Trying to access SD card on Samsung S9+ and getting error message

Hi When I open File Manager I can see that I have 64 GB of internal storage with 44.5 GB free. It also shows my SD card total 256 GB with 120.3 GB free. However when I tap on the SD card I get an error message - “Error: Permission Denial: opening provider” Can someone help with accessing it please?

Regain your privacy! Adopt /e/OS the unGoogled mobile OS and online servicesphone

Apologies - that was only part of a long error message. The full message reads:
Error: Permission Denial: opening provider from ProcessRecord{7392618 10240:com.ghostsq.commander/u0a109} (pid=10240, uid=10109) requires that you obtain access using ACTION_OPEN_DOCUMENT or related APIs
I’m afraid I have no idea what this means!

Seeing your part 2 is com.ghostsq.commander Ghost Commander on your device?

Close all running apps and start in Safe mode with Press Power then Long press the Power off icon, any change?

Next step, Soft reset your Samsung with Power + Volume down and try again (no data will be lost). You probably have to provide the necessary permission and you should be prompted to do this (but maybe you have already). is the system app External storage. You might clear cache and storage there.

Settings > Apps and notifications > See all… apps > Show system > tap on External storage > Tap on Storage.

(I assume you already tried press eject button then restart; and take the card out and gently check it is clean.)

1 Like

I worked my way through your suggestions and I’m not sure which one sorted it but it seems fine now. Many thanks for your assistance!

1 Like