Turn off vibration on notification


I wonder if there is a way to turn off vibration on notification? I don’t seem to find it in settings and I don’t get any hits when I search for it here.

Best regards

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

There are different ways. Pls search your settings

1 Like

It’s all over the place, it annoys me every time I want to disable it, would be cool /e/ found a way to disable all vibration at once.

I looked for vibration and I found an option for vibration on call but nothing for notifications. It seems that applications can choose to vibrate on notifications, for Instance Telegram vibrates but K9-Mail does not. Maybe the solution would be to setup an authorization to vibrate for each/all app(s)? I did not find this for now.

1 Like

If I don’t miss anything, the only way to turn off vibration is :

  • directly in the settings of the app,
  • maybe in Settings > Security & Privacy > Trust > Privacy Guard > Long press on an app > disable vibration (if it appears).
  • modify the notification priority to set it to “show up but make no sound” (or something like that).
1 Like

For Telegram application (and only for Telegram):

  • in Telegram settings: not found;
  • in Privacy Guard: found, thanks! I did not explore this until now and I discover many things thanks to this tool;
  • notification priority: Telegram has one category for each person, and it can delete / create categories, so while it is possible to set vibration on/off for these categories, it seems that it can be erased in the future so is not a viable solution.

Telegram > Settings > Notifications & Sounds > Private Chats (for instance) > Vibrate > Disabled.

I think its a big mess, isn’t there a master switch which overrules all app specific settings?

1 Like

Thanks, did not notice that there was a possibility to get more options than just the on/off switch. This solution is cleaner, will do this and enable back vibration in Privacy Guard.

Yes I know this is an older thread but I am a new user and I too want some way to understand how and where to disable vibration notifications.

I was able to turn it off for vibrating at certain times but I want a way to turn off all vibrations without a whole lot of fanfare. Do I need to setup different profiles? How do I turn off vibration for the stock email client? It’s not in that Mail apps Settings > Notifications where it belongs. That area only lets me choose a “Quiet time”. It’s not in the system settings > apps & notifications > mail > app notications either…

Yes I’m experiencing growing pains and I’m not averse to work. I just feel like I’m using a device from 2008.

Quickly, sorry:

Settings > Sounds > Advanced