Two problems with Q install on Sony Xpepria XA2

Well, I flashed the official stock 8 ROM from Sony on my Xperia XA2 to make sure all was good and then installed the Android 10 OS. I had /e/ running Pie before flashing with the Sony stock ROM using FlashTool. Everything seemed to install just fine but there are 2 quirks.

First is the installed phone app keeps crashing. Reading another poster here who recently had this same problem pointed me in the right direction. The problem is the app itself and it was recommended to use an app called Simple Dialer. I found a couple of these and the first 2 didn’t work. The third did and I found with Aurora Store.

The second problem became apparent about an hour later when I realized that some of my sounds aren’t working now. Notification sounds work fine out of the main speaker but any music or media is muted. Wired headphones don’t work either. The only way to hear music is with a Bluetooth speaker or headphones. Fortunately it pairs with all of my BT devices now.

Any ideas of how to get the music to play from the main speaker? I tried both the AntennaPod app and Brave browser streaming music. Maybe I just need another app?


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

I think you would have been better returning to stock 9 for installing the latest eOS-q, don’t know why you chose 8.

Returning to stock 8 would only have made sense a few weeks ago if you were wanting to install the current official eOS version at that time: which was eOS-o

Just transferred an album to my XA2 to test this, and it plays through speaker and wired ear buds, vol up and down working also.

My Sony is H3123. The stock file I flashed said it was 9 but once installed I realized was misnamed and was 8. However I think the speaker wouldn’t work for anything if the kernel got messed up and it does work for tap sounds and notifications so I think it’s a problem with sound settings. Everything in settings>sound looks good so I don’t know where other sound settings are.

Here is what I see and media isn’t muted:

That last setting for Notification Volume just puts all the volumes on the same level so the button can control them. The Notifications do work.


(Why) is there a difference flashing from different versions? Do parts of the vanilla os remain?

If so, maybe op has flashed a wrong image for wrong device maybe too due to wrong naming. Though I think that would not work at all?!

The installation page for /e/ says don’t go backwards in version numbers or u risk bricking the device. I started at Android 9 and tried to find a stock Android 9 ftf file. But the file I used was labeled as version 9 but when I flashed it I realized it was actually version 8 and misnamed. Fortunately my phone didn’t brick, though and everything went smoothly. Then I upgraded to latest /e/ for our phone which is Android 10.

I think the audio problem has to do with the settings that I can’t get to easily or there are 2 modules in the kernel for audio and now I only have 1. I’ve built kernels before and never seen multiple driver modules for a device. The latter situation seems unlikely to me that it’s a kernel problem.


Can’t give you a technical answer but my understanding is that custom roms are built on top of stock android. I know e do not provide firmware as part of their builds, e is a fork of Lineage, and Lineage recommend having stock android 9 before installing their os at the moment. Anyway it just seems a good idea to have the latest firmware for your device.

Ah. Well my XA2 is pioneer H3113. So different devices and OS builds.Presume the little on-screen pop-up volume level you get when pressing vol button is in sync with the main settings? Maybe it’s a bug. I’ve had a look in the issues page for e but couldn’t see anything related. Might be worth another look.

1 Like

I can live can live with it since it works well with Bluetooth speakers and the OS is stable. Maybe I just need to flash a kernel but I don’t wanna brick this and will see if other people have similar issues before reporting an issue on github.

Oh and I like how it has a VoLTE key now! :blush:

VoLTE screenshot


Maybe you’ll get some more input from other users with a bit more know-how, with a bit of luck. I don’t know why but XA2 posts don’t seem to get much help. When I was having many problems starting out last year with this device I didn’t get a lot of help; just had to muddle through, bootloops all over the place!
Anyhow, good luck. :grinning:

Curiosity got the better of me. I put stock android 8 on my spare XA2, installed eOS Q, and I’m now seeing how it goes.

So far so good and no sound problems with media, headphones.

I was wondering what happened. Before I flashed stock on it I was trying to restore my nandroid backup of stock 9 and it soft bricked and hung at the Sony screen. Somebody in another thread told me those backups aren’t reliable because they were encrypted by my lockscreen code so future backups should not have a lock code. I got out of it by force powering down - press volume up and power buttons till the phone vibrates 3 times. Then getting into TWRP was a mess because /e/ pie only had lineage recovery.

I wound up getting into TWRP but all this took about an hour, it was very late and I was tired and not thinking right. I wanted to wipe it and followed the directions to install /e/ pie but did too much and wiped everything but micro SD.

Apparently Sony had drivers on one of those partitions I wiped. Flashing stock 8 ROM after this (the next day I followed a YouTube video for this and checked all the install options in flash tool) did not restore the drivers for the audio it seems.

I’m not sure if other tech people create such problems for themselves!! :rofl:

Now what?:thinking:


Where did you do the wiping in twrp? Was it on this screen? If it was, then I don’t think anything drastic would have been wiped. Re-flashing stock should restore everything anyway. But I’m no tech expert. Could do with the help of someone more proficient such as @petefoth (hope you don’t mind me pinging you here :grimacing:)

I have a similar issue with my XA2 where it does not play any media, only ringtones and keystrokes.
I bought a second hand (but never used) XA2 H3113 with Android 8 on it and installed the e-0.14-q-20210204100104-dev-pioneer version - no media sound. After trying to install twrp afterwards (wanted to use twrp to boot from slot A to see if that changes anything) I ended in a soft brick (reboot loop).

So, you can see that I have no experience / knowhow with phones :wink:

I then used Emma (Sony flash tool) to re-install Android, but accidental installed Android 9. When I realized I re-installed Android 8 using Emma and installed e again.

My next step would be to install Android 9 and then e-0.14-q-20210204100104-dev-pioneer to try if it resolves the issue. Does that make sense? Is the Android version used before installing e important?

1 Like

I don’t mind at all, though I’m not sure I can help very much :slight_smile: As far as I know*, the /e/ ROMs include both a system image and a boot image, so installing the e-…zip file should give you everything you need.

* But I may be wrong here

1 Like

Things like drivers for sound would be included in /system yes?

I’m not sure. I would have thought that low-level stuff (like audio and video drivers) would be in the boot image, but I don’t know for sure. I’ve never really looked that closely at the stuff I build :slight_smile:

Ah @303max, you have made my afternoon with that post!! :joy: Today I feel to be in good company. To get the twrp screenshot you see above, I meant only to temporarily boot twrp on my phone, but accidentally flashed it. So had to install e again.

Makes perfect sense.

I have been asking myself this question the last couple of days and may create a separate topic. But I believe on some devices it does. There were a lot of problems with some devices upgrading to Q some weeks back.

1 Like

Yes, that screen. I wiped the first 4 partitions.


I don’t think divers are in /system as the /e/ install for pie said wipe the first 2 areas.

Maybe in /data or internal storage.

Edit :I fixed things to make understandable.


Marty, I’m getting confused now.
Interesting how @303max has similar sound problem, and his phone is XA2 pioneer. Wait and see what his next e install turns out like?