Two problems with Q install on Sony Xpepria XA2

Yes. Thought you were going to do that anyway. Much as I dislike windows, Emma is best/easiest for me. Pick the right one: Full content erase or whatever it is

When you see < and > : they are just placeholders, or brackets, for yo to put the info of your choice into.

If you were going to install, you would type:

fastboot flash boot recovery-e-0.14-q-20210204100103-dev-pioneer.img

After that the screen stays black, in fastboot mode. Pull plug, rest, then manual reboot recovery by holding pwr/vol down (sorry for obvious repetitions). Plug back in again before sideloading OS zip.

Don’t worry if you forget to plug back in. Command will fail and remind you. :wink: Just plug back in then re-enter command.

Let us know if Emma works. I’ve never tried it because I mainly use Linux but I do have an old Win PC.


Emma is so easy, and it’s Sony. Ive been on Linux last ten years, but got windows on old laptop just for Emma. Had to be above windows 7 though.

I think I have Win 10. It probably finds official stock Roms and I doubt mine was since it was mislabeled.


Emma works fine on Win 10. I found two Roms using Emma. One is Android 8 and the other Android 9. The one with the higher number is Android 10.

I think you misunderstood my question. I am confused on how to boot explicitly on slot A.
The note in the llineage install instructions:

Note: Newer fastboot releases dropped legacy A/B support, so it might attempt to flash to boot__a / boot__b rather than boot_a / boot_b if you try to flash boot. In this case, you must manually specify which slot to flash to based on what slot fastboot failed to flash to. For example, if fastboot fails to flash to boot__a, you must flash to boot_a.

So, do I rename the recovery partition to something like recovery-e-0.14-q-20210204100103-dev-pioneer_a.img to boot it to slot a?

I think it is not important as I will use the copy-partition script anyways but nevertheless I would like to understand how to explicitly boot an image to a specific slot.

Some useful info for you:

There is no recovery partition as such on A/B slot devices. The recovery is flashed into the boot partition temporarily.

eOS operating system zip comes with it’s own recovery (e-recovery) which as the OS installs will overwrite whatever recovery.img you used for the installation process. So if you use twrp to install by the time you have finished and booted up e, twrp will have been overwritten.

To specify which slot you want to boot the recovery to you can either specify in the command like so:

fastboot flash boot_a <recovery.img>

or you can see what slot you are on in fastboot mode with fastboot command:

fastboot getvar current-slot

If you were on slot b, say,change with:

fastboot --set-active=a

When you boot a recovery on whichever slot to install a rom , the system will boot onto the other slot.

If you are going to install eOS from stock android 9 you don’t need to do any of this if you follow the steps in my post #24 further up this thread. eOS will install to slot b and when booted you will see an OTA update to download in the system updater. Install that on- device and it will go to slot a.

Hope this helps.

Great, sound is working now :smiley:
@chrisrg Thank you for sharing your know-how!

What I did:

  1. Installed Android 9 using Emma (Sony flash tool) the version is called something like 50.2.A… (sound was playing with Android 9)
  2. Followed the instructions of and used the lineage recovery instead of twrp (like chrisrg suggested)
  3. Installed the penultimate /e/ version ( [] ) as chrisrg suggested

Now I have /e/ with media sound :wink: Still need to do an OTA after lunch :wink:

1 Like

Successfully did the OTA update as well. Media sound is still working! :wink:

Nice clean install with e on both slots; good job
Interesting though that I have same e-versions on both slots having installed over android 8.

Some interesting news to report. As you know I flashed stock android 8 onto my phone followed by flashing eOS Q to test this issue. And there turned out to be no problem with sound. What I didn’t say was that I had flashed the “oldest” Q version from the downloads page.:

The benefit of flashing older version first is that one can try out OTA updates. Downloaded the update in the system updater and followed the prompts to have it install on-device in the background. Now phone has e-0.14-q-20210204100104-dev-pioneer on the other slot and guess what? Sound not working properly.I’m assuming you flashed the most recent version?

You could try flashing the older version on yours. Might be an idea to flash over your current version as it may possibly throw errors otherwise; to do with trying to install an older version than what you already have. To do this you would have to make sure you were temporary booting recovery on the opposite slot to your current slot.

Nice-that did occur to me…you’re right, I did install the most recent ROM. I’ll try to flash the older Q ROM over this.


I don’t like the idea of going backwards even in same Android version. I’m gonna wipe this thing and do a fresh install of and then do OTA update if the sound in media works again.


Good plan. What I was getting at by booting twrp on inactive slot (if youre using twrp that is, I was kind of assuming that’s what you wanted to do) you can wipe system from there: and it would be wiping system on the other slot. Same with e-recovery.

It’s not a big deal anyway because wiping of system happens when the installation takes place.

Data though: that’s a shared partition.

What size is slot A and Slot B? When I look at storage space of internal it’s about 32 GB which is my entire drive and I would think it’s a lot less.


Getting too detailed for now! Cooking, wine, chill time, uK timezone. But I believe the partitions don’t take that much . more tomorrow maybe.

Well the media sound didn’t work for me on the /e/ release for either. I made an unencrypted nandroid backup of the latter Q that I had installed so I can go back and am restoring it now. Maybe I can get stock Sony on the other slot?

The 100103 version of /e/ is on slot A now and I restored the 100104 version on slot B.


Actually I think the 2 slots are just so 1 OS will boot. When I pick slot A it goes nowhere unit I pick slot B and then it goes into my backup of the latest /e/ version of 100104.


Marty, it just occurred to me what your problem with the stock rom might have been. I checked back on my notes to last July when I was trying to flash stock android 9. At that point in time I was using Androxyde Flashtool for flashing and Xperifirm for the rom, which I’m guessing is what you have too.

Flashtool was ok for android 8, but nothing worked to get 9 onto the phone. I tried various supposed fixes including altering the flashing script.

Eventually I tried Newflasher, still getting the firmware from Xperifirm, and this worked fine. (Later I set windows up with Emma which I mostly use now.)

1 Like

Thanks! I’ll try to get my phone totally working in a couple weeks with that flashing tool. I’m not sure where the stock rom came from but I think I need to flash stock from Xperifirm and make sure everything works on the phone before upgrading to /e/.