TWRP backup failed , why?

Hi folks
I use a galaxy S9 bought from /e/shop , everything is OK ( /e/ is a f… good OS ! )
yesterday i booted in recovery mode , launched a full backup (all partitions selected) on a 16 Go SD card ( 15 Go available )
backup begun , and stop with " backup failed " and no more information on failure causes
any ideas ?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

According to the shop page, the S9 has 64 GB internal storage. Are you sure that everything you wanted to backup would fit on a 16 GB SD card?

And the obligatory hint: TWRP doesn’t do a full backup. You might want to take care of your user data by other means (copying it via USB while TWRP is running, for instance) …

1 Like


Do you have Shelter and/or Magisk installed ?

Here is how I solved a #255 backup error : [HOWTO] Backup and Restore Data on Android Devices - #51 by smu44
You may upload your log file somewhere (please remove any personal information first, if any), then post the link here.

Thanks for your ansers …

@ AnotherElk , recovery.log file says :
I:Calculating backup details…

  • Nombre de partitions à sauvegarder : 9
  • Taille totale des données: 11078MB ( total data size )
  • Espace disponible: 15120MB ( free space )
    it seems place available in enough

@ smu44
1 - no Shelter neither Magisk installed
2 - which are personal information in recovery.log , i did’nt find any

end of recovery.log :
Sauvegarde Image Système…
I:Reading ‘/dev/block/sda18’, writing ‘/external_sd/TWRP/BACKUPS/2ad5298f3a037ece/2021-12-22–05-49-48_e_starlte-userdebug_810_OPM7181205001_68aa9/’
Truncating string cache entries.
Truncating string cache entries.
I:TWFunc::Set_Brightness: Setting brightness control to 5
I:TWFunc::Set_Brightness: Setting brightness control to 0
I:TWFunc::Set_Brightness: Setting brightness control to 12800
Truncating string cache entries.
Truncating string cache entries.
I:Error writing destination fd (No such file or directory)
Backup Failed. Cleaning Backup Folder.

1 Like

The internet says you may want to check in which file system your SD card is formatted.

1 Like

Good question … , i suppose fat32 ,
but how can i check it ? ( like a terminal with sudo parted -l )

If you know your way around the Linux terminal, TWRP - Advanced - Terminal.

Else you can do a basic check with TWRP - Wipe - Advanced Wipe - (select Micro SD Card) - Repair or Change File System - (file system will be given near the top of the screen).
TWRP might not distinguish between different FAT formats in case it displays “fat” there, but you can also format the card there by choosing “Change File System” to make sure TWRP can handle the card.

1 Like

Grüezi ,
ich bin ein Esel ! :hot_face:
un vielen Dank Another Elk :grinning: , frohes Fest

I am stupid ! * cat /etc/fstab* tolds me : vfat
and 1 of my files to save was > 4 Go , so reformat my SD card in exfat solved this issue

1 Like