TWRP don't show the menu

When I install TWRP on my SAMSUNG GALAXY S7 EDGE and reboot in recovery mode, TWRP stay blocked on the first page and do not show the menu.
I have tried to reinstall TWRP with ODIN or HEIMDALL : no more succes
I have tried with version 3.3.1-0 and 3.3.0-1 : same problem

What can I do ?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hi @olivier.etesse,
welcome to /e/

I hope you have downloaded the right version of TWRP for you phone model.
What is you phone model ? and witch version of /e/ do you plan to install ?

I suppose you know you have to swipe on the fist TWRP screen.
and i suppose you have already tried to reboot manually into recovery.

Below are the first three screens after successful installation and TWRP start.

Odin3 flash :: twrp-3.3.1-0-hero2lte.img.tar
Heimdall flash :: twrp-3.3.1-0-hero2lte.img

If TWRP Recovery cannot be installed at all, I would flash stockROM with standard Android Recovery again and start from scratch. TWRP 3.3.1-0 works fine for me on the S7 Edge SM-G935F.

My phone is Samsung Galaxy S7 EDGE 365F (hero2lte) I bought it with /e/ pre-installed and use /e/ since last year. When i tried the last OTA update (2020-04-13), the upload failed during the transfer and I have no more OS. So i tried to boot in recovery mode to install an older version of /e/ and all the version available versions of /e/ failed with the message error n°7.
I thought it was maybe due to the version of TWRP, so I reboot in Download mode and install the TWRP 3.1.1-0 and when I reboot in recovery mode , TWRP show only the first page but and do not give access to the usual menu. Idem with TWRP 3.1.0-1
I will try ARCHJE advice and test Android Recovery to start from scatch.

As Acheje said, I have flashed standard Android recovery. Then I was able to download TWRP.
Now I try to install last /e/ for my smartphone : 2020-04-15 hero2lte. The transfer is OK and the installation also. And when I reboot I have the /e/ logo with the moving dot during 1 mn and the system reboot again and again…
Any advice ?
Best regards

Olivier, try a factory reset on TWRP.

For sure, you have :
formated /data, wiped /dalvik /cache /system before installing /e/
wiped /dalvik /cache after /e/ install
Choosed a " e-0.7-n hero2lte .zip "

By “Factory Reset” do you mean simply clic on the “wipe” bouton without changing default settings (wipe /data /cache /dalvik) ?

That’s what I mean:

in TWRP > Wipe > Swipe to Factory Reset

0001 0002

1 Like

I tried Factory reset in TWRP and the boot start and stay always on the logo /e/ with only the dot who is moving.

I will try as soon as possible the last e-0.7-n version available for the device hero2lte.

Right, try /e/ OS ROM e-0.7-n-2020032947313-dev-hero2lte and make a strict “Clean install”:

TWRP > Wipe > Format Data

TWRP > Wipe > Advanced Wipe >
Dalvik /Art Cache
Internal Storage

>>> Swipe to Wipe

If it works, then do an OTA update…

I have 4 red messages E:recv error on uevent during the command adb sideload

Strict install of /e/ OS ROM e-0.7-n-2020032947313-dev-hero2lte

Despite the messages E:recv message, the adb sideload terminated with success.
But when I reboot the smartphone, it always stays in the /e/ logo
I also try with adb push and then twrp install and it is the same. I download the /e/ OS ROM again to avoid a corrupt download. I try under Linux and Windows 10. Always the same.
I begin to suspect a hardware problem :thinking:

Hardware problems? Hmm, but then why does StockROM work?

I just did the following test with my S7 Edge “hero2lte”:

  1. StockROM Android Oero 8.0.0 Secupatch Nov. 2019 flashed
  2. twrp-3.3.1-0-hero2lte flashed
  3. e-0.8-n-2020041549770-dev-hero2lte installed

Result: /e/ OS starts without errors and without problems.

Thank you, i’ll try tomorrow

Oreo8.0.0 installed. I just want to test my S7-Edge with this OS for a few days before installing /e/OS.
On this fresh installation, the only application I have installed is Firefox. My phone is freezing or rebooting alone even if I do nothing after a restart.
I have also reinstalled TWRP and when I reboot in recovery mode, even TWRP is freezing …
What is the Howto to contact SAV to send back my phone I bought with /e/OS preinstalled a few month ago ?
Thank you

It’s worth a try. I would contact @alexis [ → ], describe the problems to him, etc…

Thank you
I contacted @Thierry 1H ago. I hope he can help me.