Twrp problem - Moto (Cedric/XT1676)

I’m attempting to backup my Motorola Moto (Cedric/XT1676) with twrp.

Issuing ‘fastboot flash recovery twrp-5.3.2_9-0-cedric.img’ results in ‘(bootloader) Image not signed or corrupt.’ The md5 hits so I’m a touch confused.

Regardless, trying an older img, ‘fastboot recovery twrp-5.3.1_9-0-cedric.img’ displays:

(bootloader) Image size exceeded partition limits

What’s the solution? Should I try another img?

Regain your privacy! Adopt /e/OS the deGoogled mobile OS and online servicesphone

yes, try the recovery-e

Forgive me, but I’m confused. I thought I’m to backup with twrp prior to installing /e/. Isn’t the file you referenced used to install /e/?

you are right recovery-e can install /e/OS as TWRP does,
but recovery-e cannot back-up and restore your device as it was…

i think it maybe more worthwhile to use neobackup while in stock, then restore in /e/ afterward.
Requires root by the way.

I appreciate the suggestion. Unfortunately the Neo-Backup FAQ indicates Android 8.0 is required. My Moto Cedric runs Android 7.0. I’d like to back it up prior to loading the 8.1 firmware so I can load /e/.

I wonder if I should take the “Image not signed or corrupt” seriously. I see 12 twrp Cedric img files and 11 of 12 display that error even though the md5’s hit for all 12.

TWRP is not motorola’s official

But if you unlock the bootloader, (that is needed for flashing a custom-recovery), that will wipe the /data partition

Could you upgrade OTA ? From your motorola OS…

[quote=“TWRP is not motorola’s official”[/quote]

Yes, TWRP is not a Motorola product but to me that doesn’t explain the message. And why don’t all the IMG files display “Image not signed or corrupt?”

[quote=“But if you unlock the bootloader, (that is needed for flashing a custom-recovery), that will wipe the /data partition”[/quote]

My concern isn’t losing data. I’d like to backup in case I brick the phone in flashing the 8.1 firmware or installing /e/.

[quote =“Could you upgrade OTA ? From your motorola OS…”[/quote]

I’m afraid not as that’s the first thing I tried. I’m told the phone is up to date.

When I boot the phone I receive the message "Your phone is unlocked and can’t be trusted.
Is there something else to check?

As I understand it your device is still in the world of “Official Android”. It differs by device, but “Official Android” provides many such messages to pull users up and try to persuade them from leaving the “system”. There is a point where you have to break the existing system and this is usually the point where you install a Custom recovery.

  • (Consider that the message is valid when the files you are trying to flash are corrupt relative to the existing running system.)

Are you aware of Rescue and Smart Assistant – this offers to backup as well as upgrade.

I have a bunch of Moto G5 Cedric, buyed second hand for very cheap.
I upgraded most of them to the 8.1 firmware without any issue.

If you want one of mine, just ask :wink:

Did you backup with twrp using an img file found at If so, did you receive “Image not signed or corrupt?”

Did you flash the 8.1 firmware using Motorola_Moto_G5_XT1676_CEDRIC_RETEU_DS_8.1.0_OPP28.85? Your model/models may be different.

Hello, thank you for the wise questions ^^

I didn’t backup the phones because there weren’t used by me before, no data to backup. And I wasn’t afraid of eventually bricking one of them, so no need for a system backup for me.

the firmware I used is :

I download it from various sources and compare the file to find at least two identical, in order to be sure that is wasn’t changed/moded. The ref above is from one of theses sources.

Thank you for information. It’s good to know I’m on the right track when I get to flashing the firmware.

At the risk of being pushy, I’d like to ask a favor. I realize you didn’t backup but could you?

By that I don’t mean taking a full backup, but rather, just to see if you get the same ‘Image not signed or corrupt’ message.

Specifically, could you try ‘fastboot flash recovery twrp-3.5.2_9-0-cedric.img’ (found at I ask this as we have the same phone and it’d be an apples-to-apples test and it shouldn’t take long.

I understand you had no fear of bricking your phone but this is quite new to me and is a concern. My guess is I’m making an error as the documentation makes no mention of such a message. I did find a post on xdaforums of a user encountering the error and being advised to ignore it. He did and reported the backup worked.

So if you can test this I’d be appreciative. If not I’ll certainly understand - no problem.

I can’t answer this because I didn’t try.

I have to check again, but I won’t be able to do it soon. My to-do list is kinda huge :slight_smile:
My plan is to swich from my actual Harpia (Moto G4 Play) to one of the Cedric (Moto G5) i’ve got, but as it will be a no return move (different sim size mean, once the new one got activated, the old one are dead), I must be very careful. This is on my to-do list, but I can’t find the right amount of energy, will and stamina to do it …

Anyway, what is the test you want me to perform ? Installing twrp recovery from a 8.1 stock rom ? and try a backup ?

No problem, I’m not in a rush.

I’m suggesting testing the steps at I’m wondering if you also receive the ‘Image not signed or corrupt’ message.

If you want to do a full backup that would be fine. But if you also receive the error I’ll continue, even though twrp reports an error with the file.

I recently flashed something to cedric, saw this and went back to my old logs. It said I was hitting this years ago already and apparently it didn’t matter then.


run flashing the recovery twice, without you’ll see a recovery “no command”

~/android/moto_cedric$ fastboot flash recovery recovery-e-0.18-r-20211003138751-dev-cedric.img
(bootloader) is-logical:recovery: not found
Sending 'recovery' (15694 KB)                      OKAY [  0.681s]
Writing 'recovery'                                 (bootloader) Image not signed or corrupt
OKAY [  0.329s]
Finished. Total time: 1.020s
~/android/moto_cedric$ fastboot flash recovery recovery-e-0.18-r-20211003138751-dev-cedric.img
(bootloader) is-logical:recovery: not found
Sending 'recovery' (15694 KB)                      OKAY [  0.684s]
Writing 'recovery'                                 (bootloader) Image not signed or corrupt
OKAY [  0.283s]
Finished. Total time: 0.977s

Thank you, that’s quite useful information. I’ll ignore the message and proceed.