TWRP sideload fails on G7


I’m following the guide on installing /e on the Motorola G7:

I’m using the latest adb and fastboot and twrp for the device.

When I fastboot boot twrp-3.4.0-1-river.img I get TWRP, but when I select Advanced > Sideload > Swipe to Start Sideload the Sideload fails after about 2mins. This is preventing me from doing
adb sideload I’ve tried using an earlier TWRP but with the same result.

Any ideas here please

Try this:

  1. fastboot boot twrp-3.5.1_10-0-river.img

  2. in TWRP > INSTALL >

Thanks Gianna

I take it that actually installing TWRP before the ROM and before is going to work okay when it comes to the whole project?

TWRP-Installer.ZIP installs TWRP simultaneously and securely on both drives of an A/B device. This corresponds to an installation with


fastboot flash recovery_a twrp-3.5.1_10-0-river.img
fastboot flash recovery_b twrp-3.5.1_10-0-river.img

Right so bear with me here as I’m new to this. Installing TWRP at this stage means that the copy-partitions stage is omitted and I can continue with the installation using TWRP to format and wipe as per instructions? Followed by the rom.


I was concerned about installing the ROM. I needn’t have been. Installed it via TWRP by booting the img. Sideload never worked. Brilliant system really delighted.

This topic was automatically closed after 180 days. New replies are no longer allowed.