Unable to grant permission for outlook.com in Mail App


I am moving from a Fairphone 2 to a Murena Two, both of which run on the e/ os.
My Fairphone had no problem incorporation my outlook.com email inbox into my mail app however, I cannot work out how to get this new Murena 2 to do the same?! So frustrating!

I have exactly the same issue as this person: https://forum.k9mail.app/t/unable-to-grant-permission-on-outlook-com/5275

I cannot see the solution in the thread above (just to ask for help from e Foundation. (I don’t really understand the details given there but also cannot see clear instructions of how to overcome the ‘outlook authorisation’ which does not work.

Any help much appreciated?! Thank you!

EDIT: Changing from 02Auth to standard password worked but I can’t delete this thread now!
EDIT 2: standard password stopped working within 12 hours… still looking for solution?

(your post is legitimate, I wouldn’t delete it)

if you want to use oauth2 you need to reach for k9mail. Outlook can’t hand back the auth to the /e/elo Mail Client because the msauth:// string is unchanged from k9 - Mail with Outlook/Office365 servera - #9 by tcecyk

Unfortunately, The ‘standard password’ fix only worked for 12 hours.
The phone is now telling me that my email address or password is incorrect (which I can’t comprehend as it hasn’t changed in 12 hours!)

I don’t understand what the k9, msauth:// string stuff means. Is this another app I have to download? Is this a setting I have to change?

Is anyone able to offer some direct lamens instructions as to how I can connect my outlook emails?

Thank you!!

installing k9mail will work with your account