Unable to install /e/ on Oneplus 8 with easyinstaller


I tried to install /e/ on a oneplus 8 (probably running on Android 13). It didn’t work.
So I tried manual installation and finally bricked my phone : Oneplus 8 - Manual installation leads to a phone stuck in fastboot mode - #10 by Cooler
I managed to install back Android 11.0.4 and update to, which is an International version and not a European one.
But I get stuck at the same point during the installation process (after download of the OS), although me device is compatible :

I followed the instruction about developper mode, USB options, etc. And I’m using the original oneplus cable. I tried on Linux and Windows with the same result.

Can you please tell me what I need to change ? (Don’t want to go to manual installation for now…)

Thanks !

I see two separate issues:

Here is one recent instantnoodle thread: Easy installer läd e-latest-s-instantnoodle.zip (1.18 GB) fertig und sagt Versuche es nochmals - immer wieder

I am not sure why Easy Installer attempts to load OnePlus8/e-latest-s-instantnoodle.zip (notice Android 12 S) as … compare documentation and downloadable Android 11 (R) ROMs

which led you to prepare the device for Android 11 as you say here Oneplus 8 - Manual installation leads to a phone stuck in fastboot mode - #11 by thealpman.

The reason Easy Installer stopped may in fact be different; please read any of the recent Easy Installer or easy-installer tagged threads.

Notice many feature this sort of “Download fails” or “Try again” issue.

Maybe you can dig out the log file as Howto troubleshoot issues with the easy-installer.


Thanks. I read the posts you gave me. It seems I have the « usual » checksum problem :
https://gitlab.e.foundation/e/backlog/-/issues/7099, https://gitlab.e.foundation/e/backlog/-/issues/7213

I looked here (https://images.ecloud.global/dev/instantnoodle/) and found :
The zip file is e-1.17-s-20231112351092-dev-instantnoodle.zip
The checksum file is e-1.16-s-20231019342893-dev-instantnoodle.zip

Why this mismatch ? And why does Easy-installer choose a dev S version instead of a stable R version ?

Also I read here that Easy-installer needs Android 11 to work on this phone : OnePlus 8 Pro stuck on "Rebooting in bootloader mode" step - #3 by judydudi.
Is it necessary ?

So I tried the instructions listed here : Installer stops after downloading, no error or acknowledgement just a "Try again" button - #7 by lma
It worked, but I was stuck here

with the phone like this :


I didn’t get this screen :

So after a while I interrupted the process and wanted to reset it to factory settings to start all over again.

But it looped again on this screen, so I locked to bootloader using adb/fastboot commands and now my phone is corrupt… again.

Do you know what I did wrong ??


Since your OP I have learned of this commit

OnePlus8 Promote to S and switch to dev build.

The following replicates your checksum mismatch

$ wget https://images.ecloud.global/dev/instantnoodle/e-latest-s-instantnoodle.zip.sha256sum
Saving to: ‘e-latest-s-instantnoodle.zip.sha256sum’
$ wget https://images.ecloud.global/dev/instantnoodle/e-latest-s-instantnoodle.zip
Saving to: ‘e-latest-s-instantnoodle.zip’
$ cat e-latest-s-instantnoodle.zip.sha256sum
b36c3c499df96362f9044e94b342e2a588e950eb7fb463568fff62b45d42ad9e  e-latest-s-instantnoodle.zip
$ sha256sum e-latest-s-instantnoodle.zip
69781d44166b45eb1eae447bd68d64ca6ef93ebf464fc90145df8c14b375cecb  e-latest-s-instantnoodle.zip

It is already reported at Gitlab https://gitlab.e.foundation/e/backlog/-/issues/7225#note_486310 in reference to the first link in Post #2.

I am only commenting on what you report; sorry that I cannot suggest better than continued reading of recent oneplus instantnoodle threads.

Your screenshots are variations of Yellow, Orange and Red warnings; rather intimidating !

It is worth studying the image here https://source.android.com/docs/security/features/verifiedboot/boot-flow, noticing how with yellow and orange the state should dismiss.

Read the text and note the use of

:radio_button: Press power button to pause / continue etc.

Thanks for your help.
I don’t have this option :

Press power button to pause / continue etc.

So I can’t start the phone at all. I’ll have to unbrick it again with MSM…

I’ll probably head for a careful manual installation.

Can someone tell me which version I should choose : R, S, T ? (Easy-installer is choosing S.)
And, if I choose S (or T), should I install first Android 12 (or 13) on the phone ?

It seems I have an international version (and not European), does it change anything ?


No I understand, apologies. My comment was not intended as a response to your bricked device; only to explain why an understanding of the coloured warnings can help to decide whether to or how to proceed.

I created a Github issue Easy Installer always delivers Stable build ? - No, sometimes dev #7645

Hello Iain,

Alright, thanks for the update.

So it means I should choose the latest S version ? Why not the T version ?

And, if I choose the S version (which corresponds to Android 12), should I upgrade my Android 11 before installing /e/ ?

It seems I would have to upgrade to Android 13 for a /e/ T version installation (https://doc.e.foundation/devices/instantnoodle/install) :

It would be nice to have a little more clarity on the versions : stable R, easy-installer (dev) S or dev T, I really don’t want to brick my phone again…

Thanks !

I would generally say that installing the latest version is a good idea, thus T, it has been around since about September, I am uncertain how many /e/ users have installed it or left feedback on the forum; here is a forum search, please keep reading. :slight_smile: and, yes, it would requiring update to factory Android 13.

Regarding collection of more information

In this post Oneplus 8 stuck in fastboot we see the mention of fastbootd this means that the phone has dynamic partitions. My experience of dynamic partitions is that work must be done in the correct sequence.

Feel free to comment on the Gitlab issue.

Edit I also added the checksum mismatch to the Gitlab issue here https://gitlab.e.foundation/e/backlog/-/issues/7213#note_487713.


I finally managed to :

  • unbrick my phone again using MSM
  • update to Android 13
  • manually install the latest /e/ T version (I didn’t use fastbootd)

I made some suggestions to update the istall documentation : OnePlus - 8 - instantnoodle - Documentation Suggestions - #4 by thealpman. I hope they can be taken into account.

This video helped me quite a bit : youtube.com/watch?v=aiqslJOV1Bo

Thanks again Iain for your very useful help.

1 Like