Unable to install /e/OS on OnePlus Nord

Hello all,

I recently tried to install /e/OS on my OnePlus Nord device but the “Easy Installer” process failed.
In fact there is an issue on processing with “Easy Installer” on OnePlus Nord.
Then I tried to follow the process for manual install but it’s going nuts as I am stuck on endlessly fastboot screen after unlocking the bootloader and flashing the recovery image (see first photo below).

When trying to flash appropriate stock image (which I downloaded on this page, see below for reference if needed) through the flash-all.bat script that is included in the .ZIP:

  • wiping data is OK (see second one below),
  • sending boot_a, dtbo, modem_a, recovery, vbmeta, vbmeta_system is OK (third screenshot below)
  • when rebooting in fastboot, I get the following error message: “fastboot: error: Failed to boot into userspace fastboot; one or more components might be unbootable.”,
  • then for each step I get the following: “FAILED (remote: 'Flashing is not allowed for Critical Partitions.” (fourth and fifth ones)

Then it’s stuck again on endlessly fastboot screen.

Thanks in advance for your comments, answers and help!


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hello all,

I finally succeed and unbricked my OnePlus Nord after several tries:

  • uninstalled the drivers that had been installed through Windows Update
  • reinstalled OnePlus Nord drivers while my device was plugged but not fully recognized
  • downloaded and unzip MsmDownloadTool package with 10.5.2 OxygenOS thanks to this article on XDA
  • followed instructions here - XDA again - while it wasn’t flashing my OnePlus Nord (especially the timing for rebooting on EDL mode).

After recovery on stock image, I executed again the /e/OS Easy Installer but the process never ended: I didn’t get any error message but after downloading the avicii image, unlocking the bootloader and restarting, the reboot made it automatically to stock image and it seems to recovers without any other option.
Then the Easy Installer screen stayed on “Unlocking bootloader” step without going further and I didn’t get “Continue” button.

I will try again this afternoon to proceed with manual install, now that drivers have been updated and my OPN is fully recognized.

Don’t hesitate to comment and reply on this one :slight_smile:

Have a nice day!

Hi @assess welcome to the /e/ forum. Thank you for documenting your path to recovery of the OnePlus Nord.

Feel free to paste your Easy Installer log here if you feel it might help.

Windows: C:\Users\<your username>\AppData\Local\easy-installer

Hi @aibd, please find bellow the content of the requested log file.
Thanks in advance for your help, I’ll keep waiting before proceed with manual install.

2023-08-02 13:48:21,153 DEBUG [JavaFX Application Thread] e.e.i.EasyInstaller [null:-1]
OS name = Windows 10
Java Home = C:\Program Files\easy-installer
Current working dir = C:\Program Files\easy-installer
ADB folder path = "C:\Program Files\easy-installer\bin"adb
2023-08-02 13:48:21,270 DEBUG [JavaFX Application Thread] e.e.i.EasyInstaller [null:-1] language = fr, country = FR
2023-08-02 13:48:21,511 INFO [JavaFX Application Thread] e.e.i.c.MainWindowController [null:-1] initialize()
2023-08-02 13:48:21,513 INFO [JavaFX Application Thread] e.e.i.c.MainWindowController [null:-1] loadSubScene(null)
2023-08-02 13:48:21,719 DEBUG [JavaFX Application Thread] e.e.i.EasyInstaller [null:-1] Detected screen’s size = 1536.0 x 834.0
stage’s size = 1536.0 x 834.0
2023-08-02 13:49:25,290 INFO [JavaFX Application Thread] e.e.i.c.MainWindowController [null:-1] loadSubScene(beforeYouBeginRoot)
2023-08-02 13:49:25,291 DEBUG [JavaFX Application Thread] e.e.i.c.MainWindowController [null:-1] change view()
2023-08-02 13:50:16,956 INFO [JavaFX Application Thread] e.e.i.c.MainWindowController [null:-1] loadSubScene(connectDeviceRoot)
2023-08-02 13:50:16,958 DEBUG [JavaFX Application Thread] e.e.i.c.MainWindowController [null:-1] change view()
2023-08-02 13:53:18,500 WARN [JavaFX Application Thread] e.e.i.c.s.EnableADBController [null:-1] imageName = enableADB10.png, error = java.lang.NullPointerException: Input stream must not be null
2023-08-02 13:54:17,719 WARN [JavaFX Application Thread] e.e.i.c.s.EnableADBController [null:-1] imageName = enableADB11.png, error = java.lang.NullPointerException: Input stream must not be null
2023-08-02 13:54:18,249 INFO [JavaFX Application Thread] e.e.i.c.MainWindowController [null:-1] ResetNextButtonEventHandler()
2023-08-02 13:54:18,252 WARN [JavaFX Application Thread] e.e.i.c.s.EnableADBController [null:-1] imageName = enableADB12.png, error = java.lang.NullPointerException: Input stream must not be null
2023-08-02 13:54:18,639 INFO [JavaFX Application Thread] e.e.i.c.MainWindowController [null:-1] loadSubScene(enableDevMode)
2023-08-02 13:54:18,643 DEBUG [JavaFX Application Thread] e.e.i.c.MainWindowController [null:-1] change view()
2023-08-02 13:54:39,106 INFO [JavaFX Application Thread] e.e.i.EasyInstaller [null:-1] stage is closing
2023-08-02 13:54:39,108 DEBUG [JavaFX Application Thread] e.e.i.c.MainWindowController [null:-1] onStop()

Are you sure that your device is supported ?
We can see : product name : lito

Hi @assess, in haste, that is a very short log, with no Error seen to cause the close. Are all the logs so short ?

The 3 warnings are “standard” in that they seem familiar and Edit, I see exact copy in another log.

I noticed @piero’s point at first sight. Please checkout https://community.oneplus.com/thread/1551578.

OnePlus@Some_Random_Username will be correct, but to eliminate confusion from “people who might not be certain”, you should, as any potential /e/ installer suspicion you might confirm device codename [HOWTO] Find device codename.

@piero, @aibd,
Thank you for replying.

The device is a OnePlus Nord 128GB.
Reference is AC2003 (Qualcomm = 0303N).
The “avicii” seems to refer to AC2001 but I read here that AC2003 is the same in 8GB RAM EU version.

So I can only try to install /e/OS by following manual steps?

This topic was automatically closed after 90 days. New replies are no longer allowed.