Unable to make/receive calls on Oneplus 6t


Newly switched over to /e/ OS, have had some issues, but that’s to except considering the project is in beta for my device.

Anyways, I am having some issues with my SIM card. I have no issues with sending and receiving SMS and MMS, but I am unable to to receive and send phone calls. The issue started after I installed /e/ OS. The mobile data signal suddenly disconnects when I try calling any number, resulting an error message you can see in this video:


Just to be sure, I talked to my phone carrier, but there’s no issues on their end.

Practical info:

Oneplus 6t
Android version 10
eOS version 20

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hi Jonas,

The most obvious thing to check is the APN settings are correct for your carrier.

To be clear about your installation: you are running e-0.20-q (android 10). Before installation were you on stock android 10? If you were on 11 before installation you would be best trying the e R build.

Hi, I have checked with my phone carriers APN settings, doesn’t seem to be the issue.

My 6t was android 11, but I had to downgrade to android 10, because I was having issues booting into the /e/ recovery tool. I try installing the R build and see what happens :slight_smile:

Have you tried resetting the network stuff? Settings - System - Advanced - Reset options - Reset Wifi, mobile & Bluetooth

1 Like

I’ve now flashed my 6t to the R build: e-0.19-r-20211115146260-dev-fajita.zip, but the issue persists. @chrisrg

I also did what you recommended above, with no luck. @petefoth

Anything else that might work?

In your video it looks like you have a very weak signal to begin with which doesn’t help to troubleshoot!

I think it is important that each item in the APN setting for your carrier is exactly as it should be. Just one small mismatch can make a difference.

Is wifi calling an option in your mobile network settings? Try that.

all dialer apps? Tried others?

Found the issue, I had beforehand downgraded to oxygen os 10, which for some reason seemed to screw up the mobile data signal. I flashed my 6t with oos 10, updated it to oos 11, then preceded with the installation. Works like a charm now!

1 Like