Unable to restore call log back-up

After installing /e/OS on a Samsung Galaxy S8 everything seems to be working fine, except for a small problem restoring a call log back-up.
Before the install I created a back-up of my previous SMS messages using " SMS Import/Export" installed from F-Droid. I also created another back-up of my call-log using the same application.
While there was no problem restoring the .json back-up of the SMS messsages, I am unable to restore the call-log.json file using “SMS Import/Export”.
When I click on “Import Call Log”, the file shows on the file system, but it appears greyed out and so can’t be selected for restore.
Any help in solving this problems would be greatly appreciated.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Is the app granted the necessary permissions, as explained here?
Also, how did you put the JSON back in your device? Where is it stored now?

Thanks for your reply.
I read and followed the instructions at (GitHub - tmo1/sms-ie: SMS Import / Export is a simple Android app that imports and exports SMS and MMS messages and call logs from and to JSON files.) before trying to import my SMS messages from a back-up I had created (using SMS Import / Export) before installing /e/OS and that part went just fine.
After following the instructions from that same site to import the call log back-up file (previously created with SMS Import / Export) and having double checked that SMS Import / Export has permissions to read and write Call Logs and to read Contacts, as per the instructions, I was and still am unable to import Call Logs.
If I export Call Logs, a .json file is created, but even trying to import this same file is not possible as it appears greyed out when I attempt to select it and so it can’t be restored.
Strangely enough, those same files can be copied and/or moved to different folders on my phone using the stock File Manager included with /e/OS

I put the json file back on my device using adb push from my computer:
adb push /computer_fullpath_to_jsonfile/call-logs.json /sdcard/
Also I have no problem to read the file content on the computer, so I think I can rule out a corrupt file.

I just can’t figure out why the back-up file cannot be accessed from within SMS Import / Export.

In your report you did not include doing this:

To import or wipe messages, SMS Import / Export must be the default messaging app

… just checking !

Importing SMS messages was done after setting SMS Import / Export
as the default messaging app, and there was no problem there, so I succeeded in restoring all my SMS messages from a back-up file.

I only have problems when trying to import Call Logs.

Tried to reproduce in a worst-case scenario: from R to P device, file shared with Bluetooth (had to zip/unzip it).
I can confirm the behavior you noticed :scream_cat:

Nevertheless, success came to me when using “Select” function from the awesome MiXplorer file manager :smiley_cat::

MiXplorer official web page : https://mixplorer.com/.
Official download links : [APP][2.2+] MiXplorer v6.x Released (fully-featured file manager) | XDA Forums (file name is MiXplorer_v6.58.4_B22020910.apk).
Also available in add-ons storage at addons – Google Drive.

Side note: I didn’t notice any problem when selecting the file on the R device (where the JSON was generated)… Maybe a problem with old API?

2 Likes

Installed MiXplorer, as you suggested, and then SMS Import / Export offered me the “Select” function to use MiXplorer. That did the trick and I could import the Call Log back-up file and restore my call history. So problem solved.
Thanks a lot for your help!

2 Likes