Unable to restore Signal

Hi everyone,

Not sure if this is the right place to ask this question.

I installed Signal on my Fairphone with e/os. It worked fine for quite a good while, but recently I am unable to access it. I tried uninstalling it and adding it back on, but keep getting stuck on the step where Signal wants to send an sms to my phone for authentication. I keep getting the error message that Signal can’t access the network.

I updated Signal permissions to include sms/text messages and restarted the phone, but the problem persists. I also sent myself a text on the phone with the regular sms app and it works, so it’s nothing to do with the network not working.

Does anybody have any thoughts? I can’t link a new desktop Signal set up because I get stuck with this, but also not use it on the fairphone.

Many thanks!

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone


do you have Advanced Privacy activated or do you use apps like AfWall plus or netguard? Seems is more a TCP-IP problem than a GSM.

Not using those apps, but wondering if there is any other advanced privacy active. What could I checked to verify this?
Many thanks

Search for Advanced Privacy in settings and simply turn it of. Then try the signal activation.

I did, thanks. Gave the app all possible permissions. Restarted again. Retested. Same result. I am not sure in terms of privacy what to look for. I am downloading the lastest system update for e/os … maybe it’s to do with this. I don’t know…
Haven’t updated in a while…

Update: I had to factory reset the phone to install the os update. A bit long winded, but it did the trick. I was able to receive the sms with the Signal code. All good and thanks for your help.

:+1: good to know this workaround! Have a nice day.