Unable to sideload e-1.15-r stable on oneplus 8 Pro. E: Signature verification failed. E: 21


I am trying to install the /e/ OS on my Oneplus 8 pro.
The Easy Installer did not work. After this it was a bit dramatic, the phone was stuck in a boot loop. With the manual installation, I could flash the recovery OS.

At this link section Install /e/OS point 4.
I used the command (with a linux PC)
adb sideload e-1.15-r-20230914330641-stable-instantnoodlep.zip
At 47%, the phone tells me that the Signature Verification Failed, E: 21

If I select “install anyway”, I get another error saying that the update package is older than the current build. If I install anyways, I do NOT get the expected Script succeeded result was [1.000000]. And if a reboot I end up in the fastboot…

Does somebody know what I should do? I tried the e-1.14-r and the same thing happened.


Hi @adrien0 welcome to the /e/ forum.

You chose to install the stable version of /e/ did you ensure

If installing the stable build, please ensure that the device is on the latest Android 11 firmware.

Secondly, was your phone recently updated recently ?

From https://gitlab.e.foundation/e/os/releases/-/releases we see the

:warning: Security fixes
This /e/OS v1.15 includes the Android security patches available until August.

Your phone should not have a preexisting Android SPL in advance of the proposed /e/OS build. A recently updated phone may have an SPL of September or October.

e-1.16-r- (ETA Mid October) will have Android SPL of September.

Only asking as this has been a stumbling block this week (as it is possible the instructions have changed while you working on this) everything went ok with the Flashing additional partitions section ?

1 Like

Thanks for your answer !

With my phone in recovery mode, I used the command
adb shell getprop ro.build.version.release
And it returned 12.
So I am assuming that I am on Android 12… With should be good enough.

Indeed, my phone has most likely been recently updated. I just bought it on the website back market. I can assume that the vendor could have installed updates.
Is there a way for me to check ?

I am not sure to understand the issues with the Security patches…
But in short, I may need to wait for the e-1.16-r release, right ?

About Flashing additional partitions.
I used the file at this link
And I flashed the 3 img with the commands of the tutorial.
I am now realizing that between {dtbo, vbmeta} and {recovery} I did not reboot.
I will redo it just in case.
But I did not receive any error during flashing.

Edit: I did a boot loader reboot after flashing dtbo and vbmeta. Nothing changed

Loosely speaking (I am not familiar with the device, so just in general …) the /e/ Rom at a certain Android version, in this case 11, should be installed on a manufacturer firmware which is the latest firmware revision at that Android version. So when you see

the update package is older than the current build.

this is the mismatch likely referred to.

… understood. This might have been an alternative reason for your error message, but not this time; I think we found the cause of error in Android version !

I guess the way I would look at it now … is what’s the easiest way of satisfying one of:

  • Before following these instructions please ensure that the device is on the latest Android 13 firmware.
  • If installing the stable build, please ensure that the device is on the latest Android 11 firmware.

bearing in mind that it is always easier to go forward than back !

The OnePlus community https://community.oneplus.com/ might be a place to look for options.

A search of the forum also instantnoodlep.

A source of Upgrade check for OnePlus is Oxygen Updater (Google link), it looks as if Android 13 is available for instantnoodlep.

Edit I just noticed another two mismatches you mention in your posts. is probably the most significant issue.

  • Post #1 adb sideload e-1.15-r-20230914330641-stable-instantnoodlep.zip
  • Post #3 https__images.ecloud.global/dev/instantnoodlep/recovery-IMG-e-1.15-s-20230916331435-dev-instantnoodlep.zip.

Hi @aibd,

Thanks for your help…
Unfortunately, it did not work.

The long story short, I found on this link a good OS for my phone.
And it was indeed an Android 11 (it took me a while to figure it, since I could not use adb… and weirdly, with the GUI I was FRP blocked! The phone was asking me about the old PIN).
Anyway! It was not possible to re install the recovery OS of /e/… It would just not boot. Maybe I’ve done a stupid mistake…
Though a “hack” around the FRP block I updated the phone to Android 12 and I could install the /e/ recovery OS.

So I tried again to flash the Android 11 but omitting the recovery dbto and vbmeta partitions… But at the end the all things was a huge failure, I think I broke partition slot b trying to flash again the OS from OnePlus.
I had to switch to partition a for it work… And now I am a bit worried to break the phone.

Having flashed android 11 again, the phone is FRP blocked. But I reused the “hack” into the setting to install updates, that pushed me to Android 12. And the phone is not blocked anymore… So I think I will stop here.

Thanks for your help…
I am a bit frustrated because I bought this phone specifically because it was supposed to be compatible… I feel like the easy installer should have picked up that it was on Android 12 from the begging and just told me that it would not work instead of wiping everything…

This may be where it all started from.

In the early intro pages of Easy Installer we are told to remove all accounts from the phone. The Google account is importanrt. “The FRP is enabled automatically when a Google account has been registered on the device and will be disabled if the Google account is removed from the device prior to the Factory Data Reset.”

It was at this point I wondered if this is a spoof thread !

I seem to have failed to convey earlier, “I cannot easily downgrade Android version”.

This topic was automatically closed after 90 days. New replies are no longer allowed.