Unable to upgrade manually and automatically /e/os on samsung galaxy s10+

Hello all,
I have the problem that i’m not able to upgrade the /e/OS from version 1.8.1 to 1.9 automatically.
Then I tried to do it manually with my ubuntu pc (linux-mint in reality).
But the adb don’t detect my device
Now I’ve no idea how to handle next for my problem.
Could someone give me some hints or help me? please

had a look on following websites, but without success:

I’ll be glad if someone help to handle the issue.
Thank you very much in advance for any help

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Please can you clarify, is your phone still running /e/OS nicely ?

You are only stuck with adb not recognising the device ?

In which booting mode are you trying to (presumably, first) run the command

adb devices


/e/OS seems to run fine I think, i’ve no idea what could be wrong, i’ve no access on any error log files.
Yes on my linux-mint, the adb device won’t be recognized.
It has worked for some years ago, but now not any more.
I could see the device with the lsusb command.
For any exchange with computer there no problem. but for the adb commands not.
Thus I don’t try to go further with the procedure, if I don’t have the info that the adb command work well on my pc with my phone…

That’s the question that I ask me now… In which state should be the devices.
Until now, I put it in his “casual-mode” or normal mode, and activated the developer-debug mode by taping many times on the build version number.
What is the first booting mode? is that similar with the Init modes on linux/unix ?

The thing that i find strange is that I can not deactivate thie dev-debug mode, that’s not really intuitive to find it…

In this guide

it is suggested

Caution: The default adb installation on OS like Ubuntu can be outdated and can cause errors. We would recommend that linux distribution users ensure they use the installation process given here

On my Debian 11 platform tools come from

I can find my version like this

$ cd platform-tools/
$ ./adb --version

Android Debug Bridge version 1.0.41
Version 34.0.1-9680074
Installed as ~/platform-tools/adb

It may well be worth checking that you have the highest version available.

Exactly that, best to check that you have correct communication with the device in the normal mode.

The other booting modes being

  • Download / Odin mode (where adb / fastboot does not work)
  • Recovery mode.

Please can you express this in different words if you think it might be part of the problem.

If the above is not working does it make a difference to follow closely the

Pre-Install Instructions here

you just need to boot the device in recovery mode to install the new /e/ version

Salut Piero,
if I have a look on your screenshot, I could choose to store the file on the device memory, or on its sdcards, or from pc pointed into it through the adb interface.

Preferable in my case (maybe) would be to store it on the sdcard or the intern memory. is that right?
Is that applicable for the recovery upgrade too? or only for the build ?

To be sure about the key combo to start in recovery mode.
First device shall be off, then is the cmd that “volume up” + “bixby” + “power” ?

Yes to all ! ! .

except about the recovery-e update, the recovery-e cannot manage .IMG filles to update itself (TWRP can).
In the android -->settings -->update manager -->3dot menu, there is an option to determine if the recovery must be updated along the system or not.

About system update, If you already have accepted an OTA update for /e/OS, the new /e/os.ZIP is alreedy stored in the /data/lineageos_update folder, but the recovery-e interface don’t allow you to mount and have access to the entire /data partition, only something like “/data/internal_storage” or “/data/external_storage” (TWRP does).

Hello, i’ve done the upgrade manually.
that was’nt really complicated with the info that i had.
thx @piero @aibd for your help.
I’ve not really understood how to update the recovery.
I ask me if the recovery is the alternative of twrp, or if i may use the twrp appart.

now the only thing that surprised me is the new design of the the OS.
Especially, I find the new design of the taskbar above not that quite smart.
Huge bubbles, and should tap much more to activate internet, the direct access to the bluetooth hw list disappears, this and the notification area use the whole display. And notification display is not that logic, in 2 steps swish from top to bottom, then bottom to top. More complex and illogical as before
i’m not so fine about this new ux-experiences.
Would like to have the old taskbar one (with the new os).
I’ll give my impression into the experience chat.