Uninstall default apps

Where can I find it?

Does it delete or only deactivate unwanted apps?

Are there any risks it negative consequences?

https://download.lineageos.org/extras

With root access you can delete unwanted apps.
Also know that you risk screwing your device. If unsure then don’t attempt!

1 Like

hello
uninstall system apps android without root using adb shell comments
It’s easy and useful
this comment
pm uninstall -k --user 0 < and package program name >

for example
if you want delete mail program
pm uninstall -k --user 0 foundation.e.mail

try it

5 Likes

Yes, I have tried it successfully here

It is exactly what I wanted, thanks!!

I don’t know if it’s because of that but after I uninstalled the torch light app with
pm uninstall -k --user 0 foundation.e.light
and set up some other things, my home screen is only showing me a loading circle.

Has anyone had the same issue ?
I wouldn’t expect a torch app to have such an effect on the OS but maybe I’m wrong.

If system apps are removed, unforeseeable risks are always to be expected. A combination of several changes increases the susceptibility to errors.

What does “and some other things” actually mean?

Have you ever tried how the system behaves if you just remove the e.light app alone?

Well after reflashing /e/ and re-setting up my phone without uninstalling any system app, it seems that was it.

Didn’t you think it was possible at all that it was due to “and set up some other things” ?

As far as I remember I just installed some apps. I can’t be 100% sure but I did the same setup since then and it works fine.
To be sure one would have to uninstall the torch app on a freshly installed /e/, reboot it and see what happens but I don’t have the time right now.

I’ve already tried step-by-step uninstalling …

foundation.e.blisslauncher
foundation.e.drive
com.android.apps.tag
org.lineageos.openweathermapprovider
foundation.e.weather
org.cyanogenmod.weatherservice
org.cyanogenmod.weather.provider
[org.microg] GmsCore.apk
org.microg.nlp.backend.ichnaea
org.microg.nlp.backend.nominatim
org.microg.gms.droidguard

without any negative effects on the /e/ OS system. Isn’t that crazy, right?

4 Likes

But you have to ensure that another launcher is installed BEFORE you remove Bliss. Otherwiese your device will not boot :wink:

3 Likes

I didn’t see you removed bliss. My loading issue happened on Bliss so of course we can’t tell whether any of the other apps you uninstalled would’ve messed with it.

Good thing you said mention it. I like the blisslauncher and I use it too. Nevertheless, I always have two alternatives on the device: Senior Launcher and Rootless Pixel Launcher .

@ChameleonScales and @harvey186 please consider, it was a test of curiosity and to gain experience. My deinstallation test is by no means representative. I also don’t know if it would give the same results on another device. I am already looking forward to a stable /e/ version 1.0 with the possibility of uninstalling the pre-installed apps.

1 Like

What is the difference in adb commands between the following?

adb shell pm uninstall --user 0
vs
adb uninstall --user 0

Are both commands the same? does adb shell pm uninstall actually remove the apk from the phone or just the user profile?

thanks in advance.

Yes @zypper, this is the better place to answer your question than here.


"Are both commands the same? "More or less yes. Maybe I misspelled it for a beginner. But this is not ill-will. It’s just routine. It must be direction and completeness

C:>adb devices
List of devices attached
1234eeee56789 device

C:>adb shell
a5y17lte:/ $

a5y17lte:/ $ pm uninstall -k --user 0

For example: a5y17lte:/ $ pm uninstall -k --user 0 foundation.e.weather

“adb uninstall --user 0” requires that “adb shell” has already been executed. Without having executed “adb shell” at least once, the following commands “adb-commandos” will not work.

adb shell - run remote shell interactively
adb shell <command> - run remote shell command

The command “adb shell” allows to enter the interactive shell.

The (system) apps are not completely removed from the system, but only for the current user via parameter –user 0.


See also → Android Debug Bridge (adb) is a command line tool that lets you communicate with an emulator or connected Android device.

Official pm documentation : https://developer.android.com/studio/command-line/adb#pm

As for uninstalling and delete system apps, you may also delete the apk from system partition (remounting it rw from TWRP).

I uninstalled those apps but in the bliss launcher there still are the icons!
How solve?

Solved deleting bliss data

You can uninstall pre-installed Apps. Whether “easily” applies is subjective.

To uninstall Apps permanently …

  • Note the package name of the App in Settings - Apps & notifications - (select the App) - Advanced - (the package name is given at the bottom of the page, e.g. foundation.e.calendar)

  • If not done already, make the Developer options visible by tapping on the Build number in Settings - About phone a few times until you are being declared a developer.

  • If not done already, enable Settings - System - Advanced - Developer options - Android debugging

  • Connect your phone to a computer via USB.

  • If not done already, download the current Android SDK platform tools to the computer and unzip the ZIP file to a folder you can navigate to easily.

  • Open a command line/ terminal and navigate to the folder to which you unzipped the tools. If you are unfamiliar with the command line/ terminal, here’s a really good and short 1 page introduction to everything you need for now … https://tutorial.djangogirls.org/en/intro_to_command_line/

  • Enter the adb devices command to display an ID of the phone to make sure that ADB works with the connected phone (upon first usage the phone should ask you to confirm this access from the computer, there you should also be able to select that the phone remembers that decision, if you want).

  • Uninstall the App with the command
    adb shell pm uninstall --user 0 packagename
    (instead of packagename enter the package name of the App you noted before)

  • If at some point you would want to bring an App back which was uninstalled in this way, use the command
    adb shell cmd package install-existing packagename

27 Likes

To get rid of a system app it does’t has to be uninstalled.
The app only needs to be diabled with: pm disable-user --user 0 packagename
To bring it back just use: pm enable packagename

1 Like