[UNOFFICAL BUILD] Samsung Tab A 2015 9.7 SM-T550 (gt510wifi) for /e/OS R

Samsung Tab A 2015 9.7 SM-T550 for /e/OS R-1.15


Please see sources and install instructions including recovery here:

Use it at you own risk!
Please support the developer(s)!

1 Like

Any feedback. Does it work?

Update for /e/OS-R 1.18:


Just for my understanding – the title:

[UNOFFICAL BUILD] Samsung Tab A 2015 9.7 SM-T550 for /e/OS R

is wrong, yes!?

I do have SM-T550 devices…

1 Like

So far I only have a jumping: e •

2nd M-T550 device (e-1.15-r-20230912-UNOFFICIAL-gt510wifi.zip)
Also only a jumping: e •

Up and running, 1st boot takes ~15sec

1 Like

Great. Can you please provide some feedback how this ROM works.

If anyone is interested in building a SM-P550 is (gt5note10wifi) ROM, here one finds instructions and a manifest for Android S:


Have you tried to flash the lineageos boot.img over the ronnz98 's e-1.18-r build ?
using TWRP…

Well, had a minor set back, of a mechanical nature:

Thanks, I had done that before with a different ROM from @ronnz98

But maybe for someone else: Just extract boot.IMG from a different ROM place it on the device, when in TWRP via MTP, choose install IMG in TWRP and choose boot as target.
It’s pretty simple and you can always install a full ROM again, if something doesn’t work out!



But that did not help, so it must be a step further in the boot process.

1 Like

In short: Awesome :smiley:

The one thing I really enjoy on the hardware side is the sound and now – coming from Android 5 – I get to install all the apps I like.

Being able to choose grid size and accent color, makes me very happy, too!!!
Rotating app launcher and log in screen, yeah that is nice, too!!
Calendar app with all calendars from my nextcloud and murena look pretty good, too!

Video playback with any of my apps for local media, as well as newpipe, work flawless in HD.

Drawbacks, no opengapps… in my case, only a not so well working KiwiBrowser so far.

Battery life is good, started at 55% 10h ago and it’s down to 38% now.
Browser seem to cause the highest load, but still okay.

So, this is a useful daily driver for media and casual browsing.

Any questions?




In another post someone asked what vbmeta was, it got me thinking…
@ronnz98 & @piero as its Verified Boot Metadata, is it maybe because of something in there, which stops it from booting, maybe? Any ideas, deeper knowledge?

I see no mentions of Verified Boot Meta Data on the TWRP download website or instructions in the lineageos build thread on XDA forum.

But i found :

To get a logcat, open up a terminal window.


# clear the logcat first
adb logcat -c
# start logcat trace
adb logcat > problem.txt
# reproduce problem
# wait until problem has occured, then stop trace by hitting 

Also :

You MUST use TWRP 3.5.2_9-0. Get it at.

you MUST erase all the partitions (system, data, dalvik/art cache, cache) using TWRP and MUST format your data before installing 18.1 when you are coming from stock or an earlier version of LineageOS or from another custom rom. If you get stuck at the boot animation for more than 5 minutes, it’s likely because you didn’t follow the instructions I just wrote. Dirty flashes from stock, other custom roms or older LineageOS versions are not supported and not likely to work.


Tanks @Piero
I did all of the above MUSTs on three T550, before trying @ronnz98 versions of /e and none of them booted. On two T550s I tried LOS and both booted right away…

@retiredtab the developper also wrote :

Q18. Will this rom ever become official?
A18. Never. I don’t want the responsibilities that come with being an official maintainer. In addition, I know my device trees, code organization and git commits will NOT meet LineageOS standard

what about /e/ standard ? that are based on lineageOS standard

In addition to the sources, there is a repo diff file for device specific tweaks needed to work and a roomservice.xml (local manifest file) file so you can build this rom yourself.


Actually, I just did a dirty LOS install over the third one, on which I had tried /e 1.15 from Ronald

BTW, battery life is really good

Yes, I find it’s just always a pity, if somebody figured it out and the knowledge on bits and piece gets lost. Wouldn’t it be great, if @ronnz98 could just piece together a working /e build…

Tried that yesterday, too. On two devices. Running out of options a bit.

It does not boot that far, I don’t get a adb connection.