[UNOFFICAL BUILD] Samsung Tab A 2015 9.7 SM-T550 (gt510wifi) for /e/OS R

@retiredtab the developper also wrote :

Q18. Will this rom ever become official?
A18. Never. I don’t want the responsibilities that come with being an official maintainer. In addition, I know my device trees, code organization and git commits will NOT meet LineageOS standard

what about /e/ standard ? that are based on lineageOS standard

In addition to the sources, there is a repo diff file for device specific tweaks needed to work and a roomservice.xml (local manifest file) file so you can build this rom yourself.


Actually, I just did a dirty LOS install over the third one, on which I had tried /e 1.15 from Ronald

BTW, battery life is really good

Yes, I find it’s just always a pity, if somebody figured it out and the knowledge on bits and piece gets lost. Wouldn’t it be great, if @ronnz98 could just piece together a working /e build…

Tried that yesterday, too. On two devices. Running out of options a bit.

It does not boot that far, I don’t get a adb connection.

Did you try the current version too?

Bit of a problem, having two threads… I did not look at that one at all, as it has no mentioning of the SM-T550 in the title.

Those I have tested in various ways:

Currently running on all three SM-T550, with no install/boot issues ever:

SM-T550 is correct for WIFI version and SM-T555 for LTE version

We have added some clarity on the thread in terms of device wording- should be clear now


Can you please try this version. I found now the correct sources and applied the needed patches:


1 Like

Sorry mate, neither dirty or clean booted.

Will try with the LOS boot.img tomorrow.

I think I put the recovery in the ZIP file if you want to try this

The recovery as such works, but no /e would boot, also not with LOS BOOT.IMG flashed.

It does flash this one fine, too:


which I have come to like, as I got 3 very usable tablets now.
Battery life still stuns me!!!

I’m still happy to test /e builds, of course

Please try the Q build:


1 Like

No luck. It does not even load the /e Boot Logo.

Flashed other boot.img, used TWRP… no boot.

Can you try Pie version please:


1 Like

Going straight to ODIN, unfortunately.
Don’t you think, with the tremendous amount of ROMs you have build by now, you could simply reach out to the LOS developers and get help on how to make your builds to boot /e ?

Did you do always a clean install. Please have a look at the XDA forum pages which TWRP is best to be used for the gt510wifi Android versions.
I usually ask if I cannot build the respective developer(s) in XDA forum. If I can build and it does not boot it might be /e/OS related. I would need someone to debug boot process…

Yes, I do clean installs, wipe & format everything.

This is sort of what I mean, get a dev to help, what /e needs to boot – after all they have figured how to boot LOS on those devices.

Q5. What TWRP should I use?
A5. You MUST use TWRP 3.5.2_9-0. Get it at.