[UNOFFICIAL BUILD] A Pi/e/ test ROM for the FP2

You could remove magisk after restoring all your apps or - if possible - you might try out version 19.2. For one of my apps root could not be hidden using version 19.3 while with 19.2 it works.

I uninstalled Magisk simply as I don’t need root exept for titanum backup… However my banking app still complains about security issues (“may be your devices is rooted”). Also the update of today didn’t help… Might the app detect, that it is an “unofficial” version of /e/?

How you uninstalled magisk? Only uninstalled app? Try flash this https://github.com/topjohnwu/Magisk/releases/download/v19.3/Magisk-uninstaller-20190604.zip also i think its not about official or unofficial /e/, its about stock vs custom rom, a lot of banking apps dont want work correctly on custom roms, if your app working good except this warning you should not worry about it.

Hi @Leon, some banking apps do not work on custom ROM. Official or unofficial once they detect that the ROM is a Custom ROM they either crash or display a message such as ‘Your device is rooted…’ and stop.

Hi @Leon,
I agree with @unknown that maybe magisk has not been correctly uninstalled. I’ve tried with Sparkasse App (the most common German banking app aka com.starfinanz.smob.android.sfinanzstatus) and it shows the “rooted” message even when using magisk hide (haven’t tried uninstalling magisk). But on a fresh installed /e/ pie (e-0.7-p-20190626-UNOFFICIAL-FP2.zip) it does NOT show that message. So it’s possibly not the fault of the /e/ pie or “unofficial” version.

OK got it. I wiped system, cache, davlik and reinstalled /e/. Now everything is running! Thanks a lot!!

1 Like

I usw the pie build now for more than two weeks! Everything works pretty nice (the only problem was that the first sync with the cloud used up my mobile data…). Thank you a lot!!

One question… Since the last update the Trebuchet Launcher was automatically gone… I searched for the current trebuchet version of LOS 16, but just found the one of LOS 15.1… Any ideas where I can find the latest version?

Not sure if it is the latest version but this apk from apkmirror works. Was testing on another device pie build.

Got trebuchet running! Also the unofficial built is working super well… Only I didn’t get any update since 2/weeks now?!

There is an issue with our Docker image which prevents building unofficial ROM’s at present. We will be updating the Docker image but it will take a couple of days. Will update when the issue is resolved.

Thank you! And do you have already ideas when to release official pie version for FP2 ? The unofficial version is running without any issues. Is there a major difference between official and unofficial?

As you might be aware we have started the release of the official /e/ Pie builds for devices. There are no concrete dates but hopefully we expect to release a few devices at a time. Interestingly most devices we tested ‘work’ well on the Pie ROM! The only difference between unofficial and official builds is there are OTA updates available for official builds. Rest the source code is all the same.

Thank you very much!! For the moment the unofficial version works perfectly

But be warned that the latest LineageOS nightly builds do not boot on FP2. This MIGHT also affect an unofficial /e/ build based on that latest releases…

if wanted i can share an unofficial fp2 build from yesterday evening, it is not yet tested though…
Edit: as mentioned by @ff2u my unofficial builds are not booting correctly.

1 Like

yeah… did want to do some builds lately … but some failed / the device is not booting due to the mentioned issue… will be on the road, so the next OTA update for my unofficial builds will not be available before end of september (and then of course also only if it works by then…)

1 Like

Apparently the fix patch has been merged, i will try and build later rhis day :slight_smile:


I’ve created a build and it works fine. :grinning:


great to hear that :slight_smile:

Lineage 16 and LOS16+microg builds were release yesterday/today… however I don’t get any OTA updates with the build of @Unknown… is it possible to change to some other unofficial builds?