[UNOFFICIAL BUILD] A Pi/e/ test ROM for the Xiaomi Redmi Note 5 Pro "whyred"

As some of you may be aware we are testing out the upgrade of our source code to Pie.

As part of that effort we have a Pi/e/ ROM for the Xiaomi Redmi Note 5 Pro “whyred”

In case any one wants to test the build you can download it from the link given below.

Before you proceed with the flashing and testing Please read the warning given below very carefully

  • Please note this is a test build.
  • Please take a backup of your data before your proceed.
  • Not all of the applications have been migrated so far to the Pie branch and so there might be flashes of Lineage code showing up especially in the setup process. You may also be asked to choose between Trebuchet and Bliss Launcher.
  • In some devices we have noticed that return to Oreo or Nougat builds after flashing the Pi/e/ ROM is not possible
    Since this device is not supported by Lineage 16.0 officially I have used the device tree from XDA developer MyCats

The device is working correctly for me

a b c

If you are ok with all the warnings given above and still want to take the ROM out for a spin the process to flash is :

Feedback and comments are welcome.


thanks for your job, it looks very interesting and promissing but when I red :

I’m a little bit scared, nowadays my oreo /e/ is working so tremendously great, stable, very fast and so beautifull that I don’t want to be forced to go back to miui default creapy system :smiley::joy:
so i will wait a bit but thanks for your initiative and bravo !

It is copy-paste text, you can always flash with fastboot method to oreo or pie stock rom, you can try /e/ pie and return to /e/ oreo easilly, if you have ARB4 (if you once flash miui10 you already have it) its no problem at all.

1 Like

To return for /e/ oreo you need flash via fastboot V10.3.1.0.OEIMIXM install official twrp https://dl.twrp.me/whyred/twrp-3.3.1-0-whyred.img.html and flash /e/ oreo zip, i think if you already running /e/ oreo on your rn5, those steps very easy for you.

1 Like

Too late for me… I’ve bricked my whyred last week when i would downgrade firmware…

Hi, I flashed my redmi note 5 pro( whyred) with the rom from the first post. I’m in love with the /e/ OS, so far everything works well. I Have some questions, Will be an update? Or the rom dies here? Any security update? What can i do to maintain this rom alive?
Big Thanks to the developer.

1 Like

Hi @Krasi thanks for testing out the Pi/e/ test build.
As mentioned these are test builds which we have made to check out how they work on specific devices. We have a small team of dedicated testers who have been building Pi/e/ ROM’s for their devices and testing it out. Thanks to some excellent support from the user who also helped us with their feedback and tested these ROM’s.
Now we are preparing to release the Pie version of /e/ . Since it is a version change there are some device specific instructions that will also be required to be shared with the users. Especially users who are currently on previous versions of the OS on their devices. Flashing Pie at least the initial build may be manual. Subsequent builds will be OTA for all devices. Once the device is on the supported list the support + patches will be regular.
Lineage dropping support for a device will not be a reason for /e/ dropping support. At present we are not dropping any device from our supported list. In fact we are adding more devices to our list of supported devices !
We are working on the infrastructure to regulate receiving security patches on all devices - especially ones not supported by Lineage but still on our list.

Hi, @Manoj thanks for the detailed info. That are good news for the owners of whyred, I‘ll wait impatient the official release of pie. Meanwhile I’ll enjoy of this fresh air (/e/ rom).

We should be coming out the Pi/e/ release announcements soon. Since it is a version change it will be for a few devices at a time .

I have problem with pie builds, first build was compiled on server, now i use my pc and all my pie builds fail at 99%, so if someone want build this rom with all updates ( fresh install required for new rom as sources changed) here is instruction:
In your /srv/e/src/PIE folder open terminal and run this commands:

sudo git clone https://github.com/MyCats/android_device_xiaomi_whyred device/xiaomi/whyred -b lineage-16.0

sudo git clone https://github.com/MyCats/android_kernel_xiaomi_whyred kernel/xiaomi/whyred -b lineage-16.0

sudo git clone https://github.com/MyCats/android_vendor_xiaomi_whyred vendor/xiaomi/whyred -b lineage-16.0

sudo git clone https://github.com/LineageOS/android_packages_resources_devicesettings packages/resources/devicesettings -b lineage-16.0

and then run this script:

sudo docker run \
-v “/srv/e/src:/srv/src:delegated” \
-v “/srv/e/zips:/srv/zips:delegated” \
-v “/srv/e/logs:/srv/logs:delegated” \
-v “/srv/e/ccache:/srv/ccache:delegated” \
-e “BRANCH_NAME=v1-pie” \
-e “DEVICE_LIST=whyred” \
-e “CUSTOM_PACKAGES=‘MuPDF GmsCore GsfProxy FakeStore com.google.android.maps.jar Mail BlissLauncher BlissIconPack MozillaNlpBackend OpenWeatherMapWeatherProvider AccountManager MagicEarth OpenCamera eDrive Weather Notes Tasks NominatimNlpBackend Light DroidGuard OpenKeychain Message Browser BrowserWebView Apps LibreOfficeViewer’” \
-e “SIGNATURE_SPOOFING=restricted” \
-e “OTA_URL=https://ota.ecloud.global/api” \
-e “REPO=https://gitlab.e.foundation/e/os/android.git” \

New build ready, download here
WARNING! I did not test this build, i don’t have this device, so use at own risk.


Thanks @andrelam, I’ll test it this weekend. What kind of flash do you recomend? I mean clean, dirty or something else?

@Krasi clean flash requried, as sources changed, this rom was build with my instructions posted higher here.

Hi @andrelam, last night I flashed the rom from your post. Flash process went well, with no issues. Now I’ll install the apps that I use daily. And if there is something that doesn’t work well, I’ll let you know.
Thanks for the effort and Your time.


You’re welcome. Glad it worked.

Hi guys, the rom from @andrelam’s post works well, until now. I’ve been trying to build on my on with the files from @Unknown’s post, but my PC always fails. What Am I doing wrong?

Can you be more specific on what goes wrong, log file or something?

Hi @andrelam, here is my log file. It’s too long and I’ll put the last few lines, It stops at 99% just as @Unknown says. I’m on Manjaro linux.

[ 98% 799/815] glob vendor/lineage/overlay/common//*
[ 98% 800/815] glob vendor/nxp/opensource/halimpl/halimpl/utils/*.cpp
[ 98% 801/815] glob vendor/nxp/opensource/interfaces/nfc/1.0/src
[ 98% 802/815] glob vendor/qcom/opensource/interfaces/display/config/1.1/src
[ 98% 803/815] glob vendor/qcom/opensource/interfaces/display/config/1.0/src
[ 98% 804/815] glob vendor/qcom/opensource/interfaces/display/config/1.2/src
[ 98% 805/815] glob vendor/qcom/opensource/interfaces/display/config/1.3/src
[ 98% 806/815] glob vendor/qcom/opensource/interfaces/display/config/1.4/src
[ 99% 807/815] glob vendor/qcom/opensource/interfaces/display/config/1.5/src
[ 99% 808/815] glob vendor/qcom/opensource/interfaces/display/config/1.6/src
[ 99% 809/815] glob vendor/qcom/opensource/interfaces/display/config/1.7/src
[ 99% 810/815] glob vendor/qcom/opensource/interfaces/wifi/1.0/src
[ 99% 811/815] glob vendor/qcom/opensource/interfaces/wifi/hostapd/1.0/src
[ 99% 812/815] glob vendor/qcom/opensource/interfaces/wifi/supplicant/1.0/src
[ 99% 813/815] glob vendor/qcom/opensource/interfaces/wifi/supplicant/2.0/src
[ 99% 814/815] glob frameworks/base/core/res/res/
ninja: error: ‘/srv/src/PIE/out/target/common/obj/JAVA_LIBRARIES/WfdCommon_intermediates/javalib.jar’, needed by ‘/srv/src/PIE/out/target/product/whyred/dex_bootjars/system/framework/boot.prof’, missing and no known rule to make it
22:32:59 ninja failed with: exit status 1

failed to build some targets (03:26 (mm:ss))

[Tue Jul 30 22:32:59 UTC 2019] Failed build for whyred
[Tue Jul 30 22:32:59 UTC 2019] Finishing build for whyred
[Tue Jul 30 22:32:59 UTC 2019] Cleaning source dir for device whyred
22:33:03 Entire build directory removed.

build completed successfully (4 seconds)

And this, i have no docker installed, so don’t shoot me if it doesn’t work:
sudo docker pull registry.gitlab.e.foundation:5000/e/os/docker-lineage-cicd:master

@andrelam, I run It twice and got exact the same error :grimacing: