[UNOFFICIAL BUILD] A Pi/e/ test ROM for the Xiaomi Redmi Note 5 Pro "whyred"

Hi @andrelam, last night I flashed the rom from your post. Flash process went well, with no issues. Now I’ll install the apps that I use daily. And if there is something that doesn’t work well, I’ll let you know.
Thanks for the effort and Your time.


You’re welcome. Glad it worked.

Hi guys, the rom from @andrelam’s post works well, until now. I’ve been trying to build on my on with the files from @Unknown’s post, but my PC always fails. What Am I doing wrong?

Can you be more specific on what goes wrong, log file or something?

Hi @andrelam, here is my log file. It’s too long and I’ll put the last few lines, It stops at 99% just as @Unknown says. I’m on Manjaro linux.

[ 98% 799/815] glob vendor/lineage/overlay/common//*
[ 98% 800/815] glob vendor/nxp/opensource/halimpl/halimpl/utils/*.cpp
[ 98% 801/815] glob vendor/nxp/opensource/interfaces/nfc/1.0/src
[ 98% 802/815] glob vendor/qcom/opensource/interfaces/display/config/1.1/src
[ 98% 803/815] glob vendor/qcom/opensource/interfaces/display/config/1.0/src
[ 98% 804/815] glob vendor/qcom/opensource/interfaces/display/config/1.2/src
[ 98% 805/815] glob vendor/qcom/opensource/interfaces/display/config/1.3/src
[ 98% 806/815] glob vendor/qcom/opensource/interfaces/display/config/1.4/src
[ 99% 807/815] glob vendor/qcom/opensource/interfaces/display/config/1.5/src
[ 99% 808/815] glob vendor/qcom/opensource/interfaces/display/config/1.6/src
[ 99% 809/815] glob vendor/qcom/opensource/interfaces/display/config/1.7/src
[ 99% 810/815] glob vendor/qcom/opensource/interfaces/wifi/1.0/src
[ 99% 811/815] glob vendor/qcom/opensource/interfaces/wifi/hostapd/1.0/src
[ 99% 812/815] glob vendor/qcom/opensource/interfaces/wifi/supplicant/1.0/src
[ 99% 813/815] glob vendor/qcom/opensource/interfaces/wifi/supplicant/2.0/src
[ 99% 814/815] glob frameworks/base/core/res/res/
ninja: error: ‘/srv/src/PIE/out/target/common/obj/JAVA_LIBRARIES/WfdCommon_intermediates/javalib.jar’, needed by ‘/srv/src/PIE/out/target/product/whyred/dex_bootjars/system/framework/boot.prof’, missing and no known rule to make it
22:32:59 ninja failed with: exit status 1

failed to build some targets (03:26 (mm:ss))

[Tue Jul 30 22:32:59 UTC 2019] Failed build for whyred
[Tue Jul 30 22:32:59 UTC 2019] Finishing build for whyred
[Tue Jul 30 22:32:59 UTC 2019] Cleaning source dir for device whyred
22:33:03 Entire build directory removed.

build completed successfully (4 seconds)

And this, i have no docker installed, so don’t shoot me if it doesn’t work:
sudo docker pull registry.gitlab.e.foundation:5000/e/os/docker-lineage-cicd:master

@andrelam, I run It twice and got exact the same error :grimacing:

And this, i have no docker installed, so don’t shoot me if it doesn’t work:
sudo docker pull registry.gitlab.e.foundation:5000/e/os/docker-lineage-cicd:master

Hi guys, I’ve been trying these days tu build a pie rom but no luck. I even installed Ubuntu and I’m still getting the same goddamn error. @andrelam how did You build it? Another question, It’s easier to build a new rom or to fetch security update on existing rom?

I used my build script. Can you please not curs here, thanks.

Oh BTW, I tried to build an Oreo just to see if everything is working well and in fact it is. But I want to build a Pie rom.

Thanks and I don’t understand what do You meen, I thot this is whyred rom thread!

I meant please don’t use the g***** word.

Oh! Ok, I’m so sorry.

Hi guys, anybody knows if will be official release of pie for this device?

Hi @Unknown, did You figure it out what was the problem to build this rom on Your pc?

Updated build https://www.androidfilehost.com/?w=files&flid=301182

Tried to install new build, black screen after sim code

I also foolishly tried to flash this and also encountered a black screen. Strangely though, the volume seemed to work as the volume side bar appeared. I wasn’t worried however, thinking I could just restore my backup of \e. When I did so, the WiFi was not functional. I reinstalled \e\ completely but still had no WiFi. This reminded me of forum posts about Roms which affect the vendor partition so I flashed a stock miui pie ROM and the WiFi was working therein but again was not upon flashing \e. This was very puzzling because every other ROM, either pie or android 10 were absolutely fine. So I tried to find a stock miui Oreo ROM and eventually found something called miui infinity. After flashing that I was able to flash my \e\ backup and the WiFi was working again.

1 Like

A new Q-build…

1 Like