[UNOFFICIAL BUILD] e-0.18-r (Red_velvet_cake/android_11_based) for Galaxy s4mini LTE (serranoltexx) GT-I9195

Thanks to @itsclarence,
here come, a first new /e/OS build based on AOSP 11 / LOS 18, with Seedvault enabled.
for a pocket-friendly device with a great 4,3"screen
the Samsung Galaxy s4mini LTE (2013)

"/e/OS red_velvet_cake flavor" build from the Community :

see **serranoltexx** Supported Models
Vendor model name codename model number
Samsung Galaxy S4 Mini serranolte GT-I9195
Samsung Galaxy S4 Mini serranolte GT-I9195L
Samsung Galaxy S4 Mini serranolte GT-I9195T
Samsung Galaxy S4 Mini serranolte GT-I9195X
Samsung Galaxy S4 Mini serranolte GT-I9197
Samsung Galaxy S4 Mini serranoltebmc SGH-I257M
Samsung Galaxy S4 Mini serranoltektt SHV-E370K

Other LTE Variants are not supported :

Vendor model name codename model number
Samsung Galaxy S4 Mini serranoltekx SHV-E370D
Samsung Galaxy S4 Mini serranoltelra SCH-I435L
Samsung Galaxy S4 Mini serranoltespr SPH-L520
Samsung Galaxy S4 Mini serranolteusc SCH-R890
Samsung Galaxy S4 Mini serranoltevzw SCH-I435

Supported devices - Google Play Help - Google Support

downloads :
( included : e-recovery for serranoltexx )
native dialer screen don’t react when incoming call, so, use “simple dialer” from “F-Droid” as default solve the problem.
as it is a mini version ( due to /system size ), so you have to add the “Magic Earth” G.P.S. app from “Aurora Store”

install Guide :
[HOWTO] install /e/ on a Samsung device successfully

custom recovery :
Download TWRP for serranoltexx

Official Nougat dev builds :
last OTA update.

Community Oreo build :

Community Pie build :
fully working !

Community Quince Tart build :
native dialer crash, use simple dialer instead

Official Documentation :
Info about Samsung Galaxy S4 Mini (International LTE) - serranoltexx


unfortunately, the screen have a bug when incomming call with Native Dialer
only the bell is ringging…

edit : ! IT IS WORKING ! using “Simple Dialer” from F-droid

Test build with Seedvault Backup Solution implemented in the system settings graphical user interface

I found some others minor bugs

  • additionally to the first no “screen when calls incoming” in native dialer, the simple dialer replacement app don’t reset the missed calls counter.
  • also, when i want to copy/paste, i need to tap paste two times, because the first attempt just delete the selection without pasting.


For those who need the latest Samsung Firmware for this device :

Official Samsung firmware GT-I9195 - Sfirmware.com

How to flash stock Firmware on Samsung device by Odin?


other expression of the same bug i think,
as for incomming calls, the alarm rings but without displaying a related screen !

On the 20200602 Pie build apps don’t register with MicroG Cloud Messaging and hence don’t show notifications.

MicroG must be outdated (there should be a way to manually update it by installing new version in /system/priv-apps)

e-0.18-r-20210814 always spell checks the main language, not the one you’re writing with. This seems to be a Lineage bug from 2020: AOSP Spell checking uses wrong dictionary (#1723) · Issues · LineageOS / issues / android · GitLab

Thanks for the reply. I found a way to get microG to work, after some digging. Toggle the Cloud Messaging ping interval in microG settings to 60 seconds so it says it’s connected. Then reinstall messaging apps, so that they can register. Then set it back to automatic once they are registered.

1 Like

Notifications don’t seem to work after all. I’m not even getting SMS notifications. I’ve tried to fix this for a while, but microG Cloud Messaging just seems to not work. Or it’s a problem with something else relating to push notifications.

Edit: I tried the Android 10 one too, with the same result. I guess I’m gonna have to go back on the official Nougat.

Just to say I own several S4 mini and I’m sad to see them stuck in 0.13 so I would gladly support any new /e/ releases. I would even put a few bucks on the table to see it officially supported.