Unofficial Build for mido

i have made a build for mido and placed it here.
Sorry it is a google drive but for now is you want to check eelo-0.2 branch / oreo /LOS 15.1 code you can use this build.
Couple of points that i would want to share

  1. It is built as on today i.e. 22 Nov UTC. the UTC new day starts here in India at about 5.30 AM. I started this build around 4 AM so it shows 22 Nov
  2. The source is the same as in the Docker build url
    there may be a few apps not available or with slightly different behavior for e.g. Weather app, Light . muPDF. These may either not be present or not work. I am assuming the same set of code is not available on the public facing server. Working on this with @rhunault .
  3. Having said that the rest almost 95% works perfectly… I had tested builds on my MiA1 have not tested for Mido as i do not have this device
  4. If you are able to flash check MicroG and the other apps if they are working.

v2 got stuck booting. When I tried to flash V1 I noticed that data was encrypted. So I had to format data and then I could flash V1 and restore my TWRP data backup.
Now I flashed LOS15.1. It started flawlessly and without problems.
Next I did another full wipe (data was not encrypted) and flashed v2 again. This time v2 booted without any problems. So I wanted to restore my data backup, but data was encrypted again. So I formatted data and restored my backup. Now v2 didn’t start anymore.
For control I flashed LOS15.1 again. Booting worked fine, data not encrypted. So again data backup restored, but now LOS didn’t start anymore. Which was clear, because data came from /e/.
Finally I made a full wipe again and flashed V2 again. V2 now runs on my mido. It’s just a pity that not all apps, e.g. AnySoftKeyboard are integrated.

Thanks again for the version. If I have a little more time, I have to build a build environment again, so that I can cook the rom myself

Now I have a big problem. I was back on v1 because of missing backups. After reflashing V1 I have no WLAN and no SIM available. I have tried V1 / V2 / LOS15. Nothing. No WLAN and SIM anymore

Is there a way you can re flash the stock ROM through Mi Flash. Remove the SIM card and put it back.

I have some alternatives : or and I found one more thing :

i agree and am slowly closing out all my google accounts. Been using it for over ten years so the ID is everywhere from my tax records to old friends :frowning:

1 Like

I downloading the original firmware and will try to flash

Not sure why the sim is not being detected. Have you tried removing and putting the sim back in. It could have moved or there could be some dust.

yes, I have tried everything. The original firmware from Xiaomi fails while flashing with TWRP. Will try tomorrow another one. Today I have enough from flshing :frowning:

Thilohas send my an link to XDA where it’s explained what to do if WLAN and SIM fails after flashing. From there I have flashed the moden.bin and now WLAN and SIM is working again. But I have tried that under Nougat so I will try Orea tomorrow again.

1 Like

Thanks Thilo. This is interesting. The question we need to find the answer to is what triggered this behavior of the SIM and wifi. Other users may also run into this issue. Also please can you share the XDA page link.

Idon’t know, why I was running.into.this issue

Here the XDA.

Why is data partition allways encrypted automatically? You have no chance to backup and restore data with twrp. And that’s the reason why I can’t flash magisK

Do you put in a passcode during setup. I think that triggers the data encryption. Have to bring in the experts here @rhunault Please can you tell us if encryption happens by default on /e/ . I still see an option under Security & Privacy > Encryption & credentials > Encrypt Phone or are these two different?

I have done nothing. I have flashed as every ROM, no question.for a password.

It seems to be a LOS issue, because when flashing LOS15.1 data was also encrypted. And it seems to be general because another - official beta user has reported that data is encrypted also on his device

Interesting, I have just tried to flash LOS 15.1 on my capricorn device and I get the error message that it only works with MIUI 8.0 . Could it be that that’s also needed on other devices ? And with wrong firmware the modem.bin is missing ??

Encryption is not set by default in /e/. But maybe it comes from device specific configuration.

It seems that it comes with LOS15 on some devices, because in Telegram group I have learned from another user, that is data partition is also encrypted.

And also the issue with missing modem.bin was reported by another unofficial user build.

Thanks for pointing for the Unofficial 0.9 Pie /e/.

Sorry but i created new topic but still i think as you helped me in past, I may have some solution from you.

I ve just install Unofficial 0.9 Pie /e/.

Before this i used LOS with Microg (version 16). I m very positive about /e/ but i think at least some features should be there. It is good to go but i face some problems like:

1 I use finance apk BHIM (installed via Aurora). i cant verify phone number. (phone number verification fails). It is must as I need it everytime.

  1. I cant register my fingerprint. it is must for security reason.

  2. At least there should be icon GRID option so that i can dump more apks icons on one page and i don’t have to swipe pages.

  3. Icon without name Option should be there.

  4. Ability to uninstall unnecessary apks.

I think first two problems are grave. if it get done, I don’t have any reason to go back to LOS.