[UNOFFICIAL BUILD] Samsung S20 Exynos e0.23

Samsung S20 e0.23 ROM

1 Like

Is this still for Android 11 only or also now for Android 12?

1 Like

E doesnt have an android 12 version yet

1 Like

Finally I could install latest lineage 19.1 unofficial build on my Samsung S20 5G

https://exynoobs.github.io/OTA/devices/x1s.html

So I think it should not take too long until e OS is hopefully also supporting this device. I like the e OS GUI much more than the lineage OS

Since e/OS/ version S is on the way would it be possible to build an unofficial build for the Samsung S20 5G - I could test this version then and provide feedback

I did compile an android S rom 2 weeks back, but that had an issue with the eOS setup UI not showing.
Waiting for the official release for the first batch of devices before another attempt.

2 Likes

thanks! Sound like a good plan - please let me know when you have it ready.
I also would build it myself with some guidance

I tried myself with

sudo docker run
-v “/srv/e/src:/srv/src”
-v “/srv/e/zips:/srv/zips”
-v “/srv/e/logs:/srv/logs”
-v “/srv/e/ccache:/srv/ccache”
-e “BRANCH_NAME=v1.5-s”
-e “DEVICE_LIST=x1s”
-e “REPO=https://gitlab.e.foundation/e/os/releases.git”
registry.gitlab.e.foundation:5000/e/os/docker-lineage-cicd:community

But that did not work…

did you try with v1.5.1-s or latest 1.6 beta now?

Any news on this? I tried myself but did not succeed yet with building S20 unofficial

You are trying to build with “sources” from Exynoobs · GitHub ? – but docker does not know this from the docker run command in Post #8:slightly_smiling_face:

As an unsupported device you need to follow this guidance Build for a6000 (not officially supported), custom keys, restricted signature spoofing with integrated microG and FDroid – (the link should point to the very foot of the page).

To build for “a6000 (not officially supported)” we are guided to use the sources including https://github.com/dev-harsh1998/android_device_lenovo_a6000

So very roughly in your case you would be looking at substituting “x1s” for “a6000” and substituting the work of Exynoobs for that of dev-harsh1998 to create your own /home/user/manifests/x1s.xml

Then you can add

 -v "/home/user/manifests:/srv/local_manifests" \

to your command and ignore the bits you don’t need out of the remainder.

Thanks! I did already sorted out with the docker commands and the local manifest files. However I did get an error which I cannot resolve myself - maybe my manifest file is also not fully correct.
Would docker command for eOS build than be similar than for the a6000 example?

Well not quite because the example is a composite involving custom keys, restricted signature spoofing with integrated microG and FDroid in addition to a “standard” build – so you don’t want those bits !

First thing I suggest is to compare your own manifest.xml with the example.

Would you like to share it ?

I’d reached out to one of the [Exynoobs] devolopers and LOS 19.1 seems to be not to be supported for x1s anyway and LOS 20 I’m too inexpericed. So I wait until someone build hopefully LOS 20 for x1s (Samsung S20 )

This is the manifest.xml…

it took some time but now I was able to build eOS R for S20 (x1s) using a correct manifest. Also for S20+ (y2s) I was able to built