[UNOFFICIAL BUILD] (Updated) Sony Xperia XZ1 Compact (lilac) e-1.5.1-s-20221110

Mind games

The designation UNOFFICIAL /e/ build is a generally common designation, but at first glance it has an emotional connotation. If ‘test keys’ (public aosp keys) are then also used for signing instead of ‘dev keys’ or ‘release keys’, the impression could arise that this is not a clean ROM build.

A designation such as custom-fork-E-xtended (CFEX) or custom-petefoth (CPET) could indicate innovative unique selling propositions similar to CUSTOM-PLUS-E.

@petefoth, I know you’re accurate, reputable and trustworthy. However, it cannot be assumed that all potential Custom ROM users know this. That’s why - let’s use positive phrases.

1 Like

In /e/ terms the designation UNOFFICIAL is clearly defined here

That is exactly what I have created. I have built using unmodified /e/ source code, using /e/'s community Docker image, all as described here

If you don’t like the current definition, please feel free to ask /e/ to change it. But at the moment, the definitions is what it is, and this build qualifies :slight_smile:

1 Like

I see from what you’ve said that I 've not been able to convey my thoughts, which were favourable to you, in words. Leaving familiar paths and trying out new ways isn’t everyone’s cup of tea. But I can easily accept that and respect your attitude. And yes, the term ‘unofficial’ has a negative connotation in my vocabulary, because the meaning comes across as being in a non-public setting, not emanating from or recognised by a person or body authorised to do so. Well, it is what it is here.

AndroidFileHost appears to be in remission. The ROM is uploaded to this folder, and is no longer available on my eCloud drive.

I have edited the original post to reflect this

Here’s a new build based on the v-1.5.1-s tag.


Details of the build here

Major functions (Calls, SMS, Bluetooth, Email, Contacts, Calendar sync) all work.

A couple of problems I noted:

  1. Couldn’t log in to /e/ account using murena.io - had to use e.email
  2. Couldn’t install Microg EN Framework - downloaded, but failed with the following error (I belive this is a know bug)

App not installed as package conflicts with an existing package

I built it on a high-spec * cloud instance from Vultr

The build - including full repo sync from scratch - completed in 1h25m, and the instance was active for just under two hours for a total cost of £3.43 (€3.93).

(* Cloud instance spec: 640 GB NVMe, 32 vCPUs, 128 GB Memory, 9 TB Bandwidth, $960/month $1.429/hour )


I am thinking of trying to get this device restored as an officially supported device. Before I start the process, it would be useful to know roughly how many people are using /e/OS on this device, whether with my unofficial R and S builds or the “hidden” official Q builds that /e/ continues to build but not publicise.

If you could either ‘like’ this post, or reply to it, I can try to work out whether it’s worth the effort :slight_smile:


Hi there, I’m using /e/ on this device since may 2021, and I’m really really glad you did the unofficial build. Thanks a lot.
I’m on the v1.5 Q build

I’ve been using the XZ1 Compact with /e/OS since the summer of 2021. Originally I used your unofficial build…for which I’m deeply grateful…and now receive and install OTA builds directly from /e/ when they arrive.

This is a great device that should be supported for as long as possible.

1 Like

This was a ‘General purpose’ ‘Optimized Cloud Compute’ instance. @rhunault suggested in Telegram that

it seems to be cheaper with CPU-optimized instance of 500 GB storage

The instance he suggested still has 32 vCPU’s, but only(!) 64GB rather than 96GB of memory. I’ll try that next time I make a build (when the v1.6-s tag appears and has been tested).

I’ve been using it for the last 3 weeks and think its awesome. The XZ1c is by far the best phone I have had (and could afford :slight_smile: . I had to message eBay sellers and get them to check the boot unlock status before scoring this one for £70 (both of my old ones weren’t unlockable).
Just before that I had reverted to my backup Z5c ( the second best phone I’d ever had) as my first degoogled phone running the official /e/OS which got me hooked but the XZ1c just has that extra edge and I really missed it.
I think it would be awesome to have it as an official build.

On another note, I spotted your post about the Tablet Z3 compact Lineage OS build and got a beauty from eBay and am running that too. Yes, I like my tech to be compact and not to track me everywhere :slight_smile:

On the big plus side of the unofficial build for the XZ1c, is the Sony camera. the camera on my Z5c with the official build is truly disappointing compared to what it was stock.

I very much appreciate all your hard work.


Am I right in thinking i might have had an OTA update in the last couple of weeks? It was either on the XZ1c or the Z5c but one of them definitely did.

The latest downloads for Z5C are dated 31st October, so you will have seen those via OTA. Not sure about the XZ1C. I don’t have a devie running /e/OS at the moment. You can check: Settings | Updates should show the name and date of the /e/OS version you are running

It says:
e__lilac-user 10 QQ3A.200805.001

the version I installed is
e-1.4-q-20220923220853-dev-lilac ( I think)

That shows the file

  • is an Andriod 10 / Q build (e__lilac-user **10** )
  • was built on October 31st, same as the Z5C v1-5 files (eng.root.20221031.195647)

So it looks like you have had an OTA update recently :slight_smile:

Cool :slight_smile:
and the Sony camera is still intact. That’s a bonus!
I am only slightly nerdy…just enough to unlock the bootloader and (after a while and a few cold sweat moments) install TWRP and then a custom ROM, so please excuse the questions;
When an update happens, I presume (as the Sony camera is still working) that it doesn’t replace the entire ROM? Just updates whatever it needs to?

No. It does replace the whole ROM. Technically the update is a complete ROM (you can install it from recovery). Installing the update will overwrite the whole of the system, boot, and vendor partitions with the images held in the ROM zip. Only the data partition remains untouched.

The reason the device still has the Sony camera after the update, is that the ROM includes the stock Sony camera (extracted from the Stock ROM and included in the build).

(In fact this is the reason that this device is not officially supported, except for OTA updates. /e/ wanted the device user interface to be the same for all users of the device, so they asked me - as the maintainer of the device as I was then - to remove the stock camera. I did not want to do that: the Sony camera is significantly better then Open Camera, and /e/'s fork of it, and I was not prepared to make the system worse, just so the UI could be the same. I therefore stepped down as the device maintainer. Without an official maintainer, /e/ stopped supporting the device officially for new users. To their credit, they have continued to build updates, and to make them available as OTA updates to users who installed the /e/ ROM when it was official.

So for now I am making unofficial Android S builds of /e/OS. These don’t include the Sony stock camera, because nobody has been able to make it work on Android versions beyond Android 10 / Q. The feedback on these S builds is quite positive, but

  1. They won’t ever have the stock Sony camera and
  2. The won’t get OTA updates, unless /e/ choose to make the device official again. You will have to install updated versions manually using TWRP (if and when I build them).

I probably won’t continue making /e/OS ROMs for much longer. I don’t use it myself, as I find that (a lightly customised build of) LineageOS for Microg meets my needs better then /e/OS. If /e/ were prepared to make the device official again I’d be happy to help get things setup, but I’m not going to get involved long term. To be honest, I’m not convinced there are enough current or potential users of /e/OS on this device to make it worthwhile doing.

1 Like

So is it possible that I might loose the Sony camera at some point via an update?

I think that is very unlikely. The Sony camera is - and I believe will remain - part of the /e/OS Android 10 / Q builds. So it will be there when you update to a newer Q build. It will only disappear if you upgrade to a higher Android version (11/R or 12/S). At the moment, I don’t believe /e/ have any plans to build such an upgrade, and if they ever did, I think you would probably have to install such an upgrade manually.

1 Like

That’s good news.
It currently does everything I need it to do so I am exceedingly happy with it as is.
The only things I have found so far that don’t work are the Advance Privacy crashes if you try to alter the location settings ( I just worked out today that is doesn’t happen if the GPS is on ) and there doesn’t seem to be a way to change the system accent colour. But I can totally live with blue :slight_smile:

I only discovered /e/OS and this whole world a few months ago when I was trying to rid my phone of google stuff that I didn’t want. The tools I found to do that only seemed to (apparently) switch them off but they were still there and I wasn’t happy.
There is stuff which wont work like my Barclays app but I realised that I totally needed to reassess what my phone is for and that I don’t need to do everything immediately. I need it to be a communication device and preferably one which doesn’t track me when I don’t want it to.

I totally love the location spoofing ( although when I fist installed /e/OS on my Z5c and tried to use it to navigate to York, it told me I was in Manilla which I thought must just be one of the things I was warned might not work with a custom ROM. Imagine how stoked I was when I found the advanced privacy settings!!)
I also love the privacy ratings in the App Lounge. Again, I have had to reassess what I want to put on my phone. Some things ( like the banking) I now leave to other devices like the house PC.

Trying to extricate myself from the tentacles of big tech whilst enjoying the bonuses of the technology.
I tried to use my old nokia and lasted a few days before I realised that many things have moved on for the better :slight_smile:


Can I ask what do you prefer on LineageOS ?