[UNOFFICIAL BUILD] (Updated) Sony Xperia XZ1 Compact (lilac) e-1.5.1-s-20221110

That same poster reported issues with those Lineage builds later on: https://forum.xda-developers.com/t/rom-havoc-os-4-6-official-r.4225905/page-6#post-84928749

Seeing issues with the SO-02K version of this phone on Lineage builds as recent as 18.1 makes me a little uneasy… especially knowing that /e/OS is a fork from Lineage. I’d imagine I could run into similar demons if I tried to install it. Not entirely sure though, still new to all of this so I don’t know a whole lot. Several users have also pointed out that NFC breaks on the Docomo model but not the western one for some reason. It’s a tiny thing, but irksome nonetheless.

Honestly it might just be worth it getting the North American model for the peace of mind knowing that it’s something petefoth and other users have tested and confirmed stuff to be working with.

In general, when deciding on a device, you want to first check the official /e/OS devices list, as well as the unofficial devices list, both of which can be found by searching these forums. Any device you choose must exactly match the full model number of that device on the list(s).

As /e/ is built on LineageOS, you can usually check XDA Developers forums for further information on specific models, in addition to /e/'s release notes. If you install an /e/OS official build, your device will receive periodic over-the-air updates of the installed /e/Android version. If you install an unofficial build, you will generally have to manually download and install any updates that become available. Your data and apps are preserved in either case, unless something goes wrong.

Depending on which country you’re in, you also want to make sure that any device you choose is certified for VoLTE on at least one of the three major carriers, because VoLTE capability is a requirement for activation and usage in some countries, e.g. the U.S. (The XZ1C G8441 is certified for VoLTE on T-mobile and any MVNO that uses T-mobile’s network.)

If there is no /e/ build for a device that has a LineageOS build and which is certified for VoLTE on available carrier(s) in your country (if VoLTE is required… and if it’s not currently required, it likely will be at some point), then you could create a device request thread for it in these forums; with enough interest, the /e/OS developers (or experienced forum members) might consider building it.

Another option available to you, if there is no /e/ build, is to install LineageOS with microG instead, and limit as much of G–gle’s exfiltration of data as you can, by using free(dom)-and-open-source apps from F-Droid instead of the Play store (as much as possible), and by installing a tracker-blocking app to block unwanted background connections. (MicroG is a replacement for G–gle Android services that helps to protect your privacy, but which may render some apps from the Play store inoperable, I believe.)

Hope this info helps somewhat. :slight_smile:

P.S. Don’t choose a Samsung. The bootloader of U.S. variants (Qualcomm) can’t be unlocked, and the EU variants (Exynos) lose VoLTE capability upon unlocking.


By the way, here is Sony’s official unlocking service:


1 Like

Very well written, that helps me a lot and will surely help people coming here from search engines.
For me I picked the XZ1C specifically because I saw this thread before buying it, and the form factor and inclusion of an 3.5mm jack. If not for petefoth’s efforts I probably would have bought an XZ2C instead.
I have a sneaking suspicion VoLTE isn’t working on this device for me, as while I can make calls they sound atrocious. Could just be the speaker quality though. If anyone else has an XZ1C could you opine on the speaker quality of the device? From what I’ve tested out of the box with the SO-02K variant I bought I’m pretty unimpressed compared to iPhone SE 2016’s single speaker. Also, with /e/OS installed does anyone know if the fingerprint scanner works? I know it’s normally not supposed to function on the G8441 model.

I’ve visited the Sony unlocking site before but unfortunately it’s only for unlocking devices that allow bootloader unlocking, and mine doesn’t without paying a sketchy tool (qUnlock / S1 Network Unlock Tool) a ransom fee of $25 change bootloader unlock allowed from NO to YES. I’ve read multiple testimonies of people on the XDA forums that have said it works, but no one has explained how it works so I don’t really trust what else it could be doing to your phone or computer.

:ballot_box_with_check: After reading through your post I think I’ve decided I want to return the phone and try again with a XZ1C G8441 model. My only other options as far as Android phones go is the XZ2C which doesn’t have a headphone jack and is pushing the limits of what I would consider to be a compact form factor or the Cubot Pocket, which also lacks a 3.5mm and might actually be too small for me with its 2:1, 4" display. Would be a great work phone though.

I doubt the Japanese DoCoMo model is certified for VoLTE on any US carriers. If it is, after you insert the SIM card for a US carrier, you should see the menu item “VoLTE” appear in the network settings, and a toggle to turn it on. If it’s not there, then the device is not certified for VoLTE with that carrier. (The G8441 only gets VoLTE with T-mobile USA, as far as I know.)

Using VoLTE will improve the audio quality of phone calls. If there’s no VoLTE, then you’re defaulted to the legacy 2G GSM tech for calls. (Of the US carriers, only T-mobile and MVNOs that use that network still have a 2G network, and not ubiquitously, and not forever, most likely.) VoLTE on the T-mobile USA network works great on my G8441 (although I currently have a recent problem with the ear speaker not conveying sound, so I have to use headphones [EDIT: or loudspeaker] for calls at the moment; it’s an issue that has already been raised with the developers).

My G8441 has the fingerprint scanner settings, and it probably works, but I don’t like the idea of storing my fingerprint image on connected devices, as I consider it a security risk. So I haven’t tested it. [EDIT: OK, I tested it, and it works. Then I deleted the fingerprint.]

I think you’re wise to return the Japanese model. About the XZ2C, if you’re considering it as an option, remember to investigate the VoLTE capability first. Some phones are only certified with selected carriers, not necessarily all carriers.

Also, one way to tell if you’re using VoLTE or not is to watch the network indicator at the top of your screen when you’re on a call. If “LTE” disappears and reverts to some lower generation (2G, etc.), then you’re not using VoLTE. (Again, the setting only appears when you insert the appropriate carrier’s SIM, at least on many devices.)

1 Like

Probably not a good idea, especially if you don’t know much about the developer.

Wow, this is super helpful! Thanks for testing that stuff for me. I’m gonna test my SIM card and see if I get VoLTE with the SO-02K model. I’ve already started the return anyway but I’m just curious if it works or not. I’ll report back my findings for the sake of anyone that lands here via search engine. I’m also using T-Mobile so the G8441 should work just fine for me.

Well it’s kind of a weird situation. Because from what I can tell I’ve never seen anyone claiming to be the developer of that program. It just seems to be a few people here and there like that guy in Canada that promote the product and sell the credits for it, but don’t actually know anything about how it works. I’m kind of surprised there’s no open source program for this sort of thing yet, yet we have a sketchy closed source one that just been floating around for years and years and people have been using it to SIM unlock or bootloader permission unlock their devices.

Alright I just put in my SIM card and checked. It seems like the SO-02K does not get voiceover LTE with T-Mobile. I get the option to enable VoLTE in the settings, and I am getting 4G cellular data with it that I can use to browser the internet and stuff quickly. But when I make calls on it the audio quality is absolute abysmal.

What I see: A “4G+” icon beside my network bars. The 4G+ icon disappears when I start a call, and when I go into the settings after starting a call the "Enable VoLTE setting becomes grayed out and I can’t toggle it. It appears to get stuck in the ON position.

edit: I’ve started the return process for my SO-02K phone and will buy a different model soon. Even though I’m not going to be using an SO-02K model I would like to see more focused /e/OS and LineageOS support for it in the future. the XZ1 Compact is a great phone, and it’d be a shame to let so many of them just rot away as e-waste no one wants. The out of box experience on those Docomo phones is absolutely atrocious and they’re stuck on Android 9 despite having very capable specs.

Latest unofficial / custom Android 12 / S build, built from the v1.12.3-s tag is available here:


I dirty flashed it over the 1.11-s build with no obvious problems

Sadly, due to my incompetence, this build is signed with public / test keys, and does not include the ‘Use Trebuchet as launcher / home sreen’ fix. I probably won’t have time to do another build to fix that, so if either of those things are imporatnt to you, then I suggest you don’t update now, and wait until the v1.13 build comes around. Sorry!

Release notes are available here


The official 1.12.3-r built hasn’t shown it’s face here yet. I’ll post again when it does

Hi. I successfully installed /e/OS 1.09Q on the G8441 I bought and then updated it OTA to 1.10Q. No matter what I do I can’t seem to get my SIM card to work on it. When I plug it in it can detect that my carrier is T-Mobile but refuses to let me make any calls or use cellular data. I have confirmed before installing /e/OS that calling and VoLTE work on this device. When I try to make a call I get an error: “Mobile network is not available. Connect to a wireless network to make a call.”
Anything I can do to help with this? I checked the SIM card with my other phone, so I know that’s not the issue. The wifi also keeps dropping connection for whatever reason.
Also as an aside, is it safe to relock the bootloader with /e/OS installed? Are there any reasons I would not want to relock the bootloader?

A couple of things to try

  1. in Settings | Network and internet | Mobile network, change ‘Preferrred network type’ to ‘3G’, reboot. Try making calls, Set back to ‘LTE’
  2. in Settings | Network and internet | Mobile network | Advanced | Access point names: check the content of the selected APN against whatever the settings should be for your network
  3. In Settings | Xperia parts:
    1. CHeck Status
    2. In Modem Switcher Activity, try different modems
  4. In Settings | System | Advanced | Reset options, choose Reset WiFi, Mobile & Bluetooth


Because your phone won’t work if you do :slight_smile: On Sony devices, if the bootloader is locked, the phone will only boot official Sony ROMs: custom ROMs won’t boot

1 Like

#1 worked for me… after fiddling with settings like wifi calling a bit. After a restart though it stops working again. Will I have to do that every time? It seems like when I’m having issue with the cellular data it also causes me to have issues with the wifi connection repeatedly cutting out too.

It’s quite temperamental and I’m having difficult replicating the solution. I’m not really sure what could be wrong with it. I’ll try out some more solutions tomorrow, but for now I need to sleep.

edit: In the morning when I checked the phone the cellular had stopped working again. The phone had also lost an unreasonable amount of battery just sitting idle overnight. 50+% lost from just sitting on standby. This is on /e/OS 1.10Q.
The device also appears to not respect some of my settings choices. For example even when turning off haptic feedback, I still get vibration when using the keyboard.

I think that those problems may be something to do with APN settings - see #2. Worth checking what your APN settings should be. Also worth, trying #4, to see if that helps

I’ll give that a shot, but even if I solve the wifi and cellular issues I highly doubt it’ll do anything to remedy the battery drain and settings bugs. Not really sure what I should do I can’t use the phone with this OS if it’s going to be like that. Should I update? Does anyone else have these problems on this phone model? /e/OS 1.10Q

Sorry, but I don’t use /e/OS on my devices. I use IodéOS or lineageos4microg. I recall that the problems you report were quite common on older builds of the upstream LOS ROM, as well as the /a/OS build.

Your Q build is the official build which is a: stuck on Android 10 / Q and b: is built from code that lags a long way behind the upstream sources. I would strongly recommend moving to a ROM made with more up-to-date device and kernel sources: either

  • this unofficial Android 12 / S build of /e/OS
  • the unofficial Android 13 /T build of IodéOS (also built by me)
  • the unofficial Android 13 / T / LOS 20 build of LineageOS4microg (also built by me) - see this XDA forum post
  • the microG version one of the unofficial LOS ROMs (17.1, 18,1 or 19.1) built by FlameFire - see this XDA forum thread.

There is no prospect of the device-specific bugs that you report being fixed in the official /e/OS build based on out-of-date code - sorry!

1 Like

I always have to boot in 2G first (T-mobile USA has no 3G anymore, by the way), then switch to LTE after the initial connection is established. Since I also frequently lose T-mobile signal inside large warehouse-type stores, I make things easy on myself by preemptively switching to 2G before I enter the store; otherwise I might have difficulty reconnecting after exiting, requiring a full reboot as a result.

And yes, this is very annoying, but at least I’ve learned how to deal with it. TIP: install a free/open-source app called Network - I got it from F-Droid - for quick access to a phone connectivity screen with an easy GSM/LTE switch, and save the app as a home screen shortcut. This will be faster and more convenient than delving into the phone settings menus every time.

The phone may have been continually searching for the network, i.e. not idle at all, hence the battery drain.

How is the T-mobile signal strength inside your home?

Understood. I am using the Q build because it has the Sony camera. But given what you said I think I’ll try the /e/OS 12 build. It looks like I can download that OTA so that’s what I’ll do and I’ll see if that fixes things. I’m wondering if I could simply have done a bad flash though? Does that happen? Is there such a thing as random chance causing bugs in an OS that reflashing would solve?

edit: Although given what you said in previous posts I’ll try 1.11 first and wait for 1.13 later. I’m in no rush.

The signal strength where I live is very good. My iPhone has no problem getting a good LTE signal. I can get the XZ1 Compact to get a signal by doing the things Pete told me to do, but it doesn’t really last.

By the way, I have the same network issue on a different model Sony that’s running LineageOS (without microG) and yet another Sony, different model again, that’s running LineageOS with microG, so it must be something in the Lineage implementations. (Neither of those other two models ever got VoLTE on T-mobile USA, though.

EDIT: Then again, other users of the XZ1c don’t appear to have this problem; at least on different carriers in different countries.