[UNOFFICIAL BUILD] (Updated) Sony Xperia XZ1 Compact (lilac) e-1.5.1-s-20221110

That’s quite a bit disconcerting as I’m hoping to use this phone as a daily driver until they come out with a USB-C iPhone that’s worth buying.

The /e/OS 1.12 build is based on the same out-of-date upstream code as the build you currently have, as will the 1.13 build. The last commit to the /e/ device tree code was more than 12 months ago. The upstream device tree code has had a lot of commits since then, the latest 5 days ago. This is because there is no official /e/ maintainer for this device, so there is no-one to merge the upstream changes into the /e/ source code.

I will be very surprised if you see any improvement in the official /e/OS builds. If you want device-specific improvements and bug fixes you need a ROM that uses up to date code.

The LOS 17.1 LOS build I mentioned still has the Sony camera

I’m just gonna try the 1.11-s version here and see how well that works. Nothing on the Android 10 Q versions is helping me.

I have upgraded from 1.12 Q to 1.11 S via sideloading in TWRP without doing a full wipe of the OS. The device continues to not respect my settings regarding keyboard haptics. It still vibrates on keyboard press even when I’ve disabled literally everything vibration related I could find in the settings. I’ve tried enabling them and then rebooting, and then disabling and then rebooting again.

I’m not gonna say “literally unusable” but this particular bug will drive me up a wall if I can’t figure out how to turn the vibration off.

edit: Nevermind. User error, or rather “UI error” is what I’d call it. To disable keyboard vibration you have to go to the keyboard settings and tap on the keyboard and disable it there. Even though in the Sound menu the haptics toggle says it disables it for the keyboard…


Now I’m having a very crucial other problem. I’m stuck in some sort of bootloop.
I tried inputting my SIM card to test network capabilities. Nothing happened so I then tried to restart the phone. After that and unlocking the phone shuts itself off and then reboots into TWRP recovery. The phone doesn’t turn itself off until I enter the PIN and unlock it. After that it shuts itself down within about 5 seconds. Not really enough time for me to do much of anything.

I have tried multiple things, I have tried hard resets, I have tried booting into safe mode, and I have tried inputting the terminal codes from this XDA thead https://forum.xda-developers.com/t/when-android-keep-booting-into-twrp-recovery.3572200/

So far nothing has worked and I don’t know why it started doing this. I don’t know if installing F-Droid had anything to do with it but I doubt it. It’s basically a brick until I can get this solved.

I’m happy you sorted the keyboard "issue: :slight_smile:

That’s probably because you upgraded from the S build to the Q build without formatting the data partition. See this post for details of how to do that.

Formatting will lose all you user-installed apps and user data, so if you don’t have an accessible backup from your Q installation, you can try re-installing the Q build without wiping or formatting, abd taking a backup of your apps and settings using Android Backup and Restore Tools project as described in point 2 of this post.

Then, in TWRP, format the data partition, re-install the S build, and restore your backed up apps and data.

Good luck.

As mentioned in other posts, it’s always a good idea to have an up-to-date backup of your apps and data. It’s handy “just in case” when updating from one /e/OS version to another (i.e. 1.11-q to 1.12-q), but it is essential when upgrading (i.e from Android 10 to 11 or 12)


If you did that then you may have blown your chances of not losing your apps and data. Those commands appear to be trying to format various partitions on your device storage. I’ve no idea what the effect of that will be. Anyway, formatting the data partition using TWRP and installing an /e/OS build should at least give you a working device

That’s fine. I haven’t had a chance to actually use this device since I bought it, so I have nothing of worth on it. I’m just a little scared of doing a full wipe and then still having the problem. I think what I’ll do is start totally fresh and flash the OEM rom back on, and then try to install /e/OS again assuming it gets me out of the bootloop.

edit: Doing a factory reset solved the boot loop. Cellular works, LTE works, but VoLTE doesn’t appear to be working on the Android 12 verison of /e/OS that I’m using. I probably won’t do much with the phone for a while as I’m in no rush to get it working. I’ll need to flash on a clean oem rom on it and then reflash /e/os and see if that fixes any of the issues that I’m having. If not I’ll have to try some of the other options. I confirmed VoLTE to work on the stock OEM so I’m not sure why it isn’t working here.

edit edit: I got VoLTE working well by going to Settings > Xperia Parts > Turning on IMS features
and then going to APN settings and reseting those to default and rebooting.
edit edit edit: But the same problems from previous versions of /e/OS I tried where the cellular needs some adjustment each time the phone is rebooted show up here. Not great.


See this post for details:

Actually the official 1.12.3 build is q rather than r and it’s here

Of course, like all the official builds for this device, the device tree and kernel code are very out-of-date. The /e/ OS and LOS code, should be up-to-date, and the LOS Security patches not lagging too far behind.


I ended up wiping my device clean and reflashing the stock OS back onto it, and then flashing /e/OS Q onto it again, this time with the SIM card already in the device. And wouldn’t you know it, it works just fine now. Bad flash maybe.

Anyways I don’t think I’m going to stick on /e/OS, considering that it has no active maintainer using it and it seems to be quite a bit behind Lineage and Iode. I think I’m going to try your Iode 4.1 build next.

Nevermind. I had a lapse in judgement and attention and dirty flashed the stock rom back onto the phone from /e/OS Q using Emma, which is the official Sony Flasher tool. Now it’s soft-bricked. Can’t get past the welcome setup wizard, it always shuts the phone down before I can get pass the screen where it prompts you to set up a password. No TWRP. Can’t get to settings to turn on USB debugging, so I can’t use ADB or fastboot commands. Very much stuck right now.

edit: Nevermind again. I was able to get TWRP flashed onto it in fastboot mode the second time without needing USB debugging. Somehow. I dunno. I’m tired.

With the IodeOS build I’m having the same issues I was having with /e/OS. Wifi and cellular constantly seem to be pit fighting with each other and crashing each other. I have confirmed just beforehand that both were working fine on stock rom.

I can’t even get calls to work at all.


The only remaining thing I can suggest is to try maybe the LOS19.1 microG version of the unofficial LOS ROMs I linked to above

If that gives the same problem (and from what @Taurus has written above, it may well do), then I’m afraid I’m right out of ideas. Sorry!

Is it possible that I’m doing something wrong? There’s no official instructions to go off of for flashing custom roms onto the XZ1 Compact so I’ve just been using the instructions for flashing the Z5 Compact on the /e/OS website.

I wrote some words about installing on lilac in the IodéOS forums

The instructions aren’t very different. One thing worth checking is which version of TWRP you have. I’f you don’t have it already, I recommend using the twrp-3.6.2_12-0-20221002-lilac.img lined above

1 Like

Ah I see. I was using a newer version of TWRP this whole time (3.70) instead. So that could be what’s been causing these bad flashing issues.

With my more recent builds (of IodéOS and LineageOS4microG) for lilac, I started to encounter the mobile data problems that have been reported previously on LOS-based ROMs for this device . Specifically, some sites and some apps which access the internet were working fine when connected via WiFi, but failing or timing out when connected via mobile data, even though the phone was showing a good 4g connection.

My network provider is Your Co-op, a UK MNVO which uses the EE network

The ‘fix’ that worked for me was to edit the EE Internet APN, changing APN type to default instead of default,supl. (I recall that I had to add the ,supl a couple of years ago to fix a similar problem). I don’t know why the problem started to occur for me, or why the ‘fix’ works, but I hope my experience might help any others who may be encountering a similar problem.

1 Like

Here are the latest / last builds from me for this device. I have made both S and T builds

  • v1.13-t e-1.13-t-20230727-UNOFFICIAL-lilac.zip

    I have clean flashed this build after formatting data with no problems. I also dirty flashed it as an upgrade over the 1.12.3-r build I didn’t see any obvious problems, but I haven’t tested extensively. Some problems have been known to happen with dirty upgrades like this, with e.g. app permissions and mobile internet access, so be prepared for the possibility of having to do a clean install if it all goes wrong.

    I have not tried a dirty upgrade over the 1.13-r build, but the same should apply

  • v1.13-s lilac e-1.13-s-20230726-UNOFFICIAL-lilac.zip

    I have only tried a clean flash of this build, but there is no reason why a dirty flash over the 1.12.3-rbuild should not work.

On a clean install of either build you should be offered a choice of which launcher to use (Bliss or Trebuchet). On a dirty install or upgrade, Bliss will remain the default launcher, but you can change to Trebuchet via Settings | Apps | Default apps.

Have fun, and good luck.

If anyone wants to take on the task of making future builds for these devices, details of how to do it are in this post, but I’m done :wave:

1 Like

Any chances to find a new maintainer for this great ROM for this great device? There are no any alternatives for people looking for a small (>5") smartphone really. Except from the older Sony Xperia Z5 Compact wich still is maintained btw (and which is my daily driver). But it will not be updatet to T it seems…
and some people (like myself) still like that :slight_smile:

ROM maintainers are volunteers who step forward from the user group.

Update for /e/OS-T 1.19: