[UNOFFICIAL BUILD] Xiaomi Mi 9 (cepheus) eOS Q-build

A new build for the Xiaomi Mi 9 (cepheus)
Make a back-up first, because this an untested build. Please share your experience


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

1 Like

Thanks i try a soon as possible.

Hi there. So, are there any news regarding /e/ on Mi 9? Has anyone tried it yet? Is there still active development?

Will /e/ ever officially support the Mi 9? I have considerable doubts about that, because ’ The LineageOS Project ’ does not support the ‘cepheus’.

The Xiaomi Mi 9 (cepheus) is a lightning-fast phone with a first-class display. My Mi 9 runs really well with LineageOS 17.1 + MicroG +….

But a recent eOS Q-build from our @itsclarence would be much appreciated and I would try it out immediately. It would also be nice if already the Android Security Patch April 5, 2021 were inetgrated, because GrapheneOS Android 11 has updated it since yesterday.

Okay…the testing can begin…@SuzieQ and @Hixx


Hello @itsclarence, you’re a magician, right … :o)|

I’m horrified to find that Xiaomi has imposed a 336 hour (14 day) wait on me this time instead of the usual 168 hour (7 day) wait before I am allowed to unlock the bootloader. The test will unfortunately have to wait a few more days. I’m inconsolable :-(|

Haha, no problem at all of course. I’m always glad with your help and advices… have a nice weekend

@itsclarence, my new Mi 9 may be unlocked from next Wednesday late at night.

Signing Builds
Generating the keys

Is there anything positive to announce?

maybe you have a crystal ball? I have been working for 2 days and many hours to discover what I am doing wrong. I hope I can figure it out … to be continued

Ha ha, oh no, I’m glad I don’t have any. Then there would be no more surprises for me.

I’m very happy to hear that they are working on it.Unofficial ROMs with test keys are the norm. Unofficial ROMs with privately signed keys are the positive exception to the rule and thus an additional quality feature for the ROM builder. It is only a small component of the whole, but it shows conscientiousness and security thinking.

He who waits with prudence,
He will be rewarded in due time.
Now the waiting has come to an end:

Mi9 runs smoothly with /e/ OS ‘Q’ e-0.16-q-20210409-UNOFFICIAL-cepheus, can make phone calls because the SIM card is recognised immediately and surfing via WLAN WiFi also works. Thank you very much, Edwin @itsclarence



I’ve been thinking about switching to /e/os for a long time , but this device (cepheus) never got an official release. Thanks for your time building it for this phone.

I have 2 questions :

  1. is it safe to use it as a daily driver ?
  2. what does it take to make it official ?

Thanks !


First of all, thank you for this build and congrats on your work!

I’d like to share an issue I’ve encountered and know if any of you had the same problem and has found a way to solve it.

After successfully, though not easily (thank you Xiaomi) unlocking the bootloader, I installed TWRP, wiped the data (data format and wipe) and I tried installing the OS by sideloading the zip file with adb.

After a while, the computer tells me I’m good and so does the phone. Unfortunately, when I want to reboot on the system from TWRP, it tells me there is no OS installed. If I reboot anyway, my phone goes back into fastboot and loops on it indefinitely until I reinstall a Xiaomi rom.

I installed e successfully on a Samsung Galaxy S8, and I remember I had to copy the zip file somewhere on the phone memory (or was it on a SD card?), thus not having to sideload the thing. Is that what I should do here too? Or do you have any idea what I’m doing wrong and how I could make it work?

Thanks a lot for your help!

Just to give some feedback on my issue.

Eventually, the problem evolved from bootlooping on fastboot to bootlooping on twrk. I tried with Lineage OS and encountered the same problem. I also tried all the solutions I could find online, unsuccessfully. I finally tried with another custom rom whose philosophy is close to /e/ : iodé. I followed the same steps as I did with /e/ and this time it worked perfectly.

So I still don’t know what went wrong and how to solve it, but I have a working ungoogled phone anyway.

I hope this is just related to my phone (or my incompetence), since it actually worked fine for other people and thanks again for all the work you put in this! :slight_smile:

EDIT : I forgot, but when installing iodé I used an older twrk version. Maybe it was twrk’s fault after all.


I’m just searching for feedback about your IodéOS version on Mi 9
Is it working properly ?
Have you encountered any specific problem ?
What about using the fingerprint identification ?

Hope you’ll notify this message, i’m craving about changing ROM, i’m so tired about this MIUI

Thx, cya

Hi Zeeko,

It works great except for the Chromecast. I was completely unable to communicate with it in any way tough that may be expected of an ungoogled phone. Apart from that, I didn’t encounter any major problems. The fingerprint identification works normally.

I didn’t have any problem during the installation process (after successfully unlocking the bootloader, that was tough, thanks Xiaomi :stuck_out_tongue:). For twrp, I recommend using the latest version from their website and not the one on Iodé’s website and github.

One advantage of Iodé over e is that you don’t need to use a vpn slot to block trackers. It is already included in the software.