Update machanism for apps completly broken?

is anyone else experiencing the problem, that the update mechanism is completly broken?

No matter if I use the apps-updater, or the Aura Store. Updates are shown, if I choose to update all, the download starts and after that the mechanism get stuck.

If I download app after app (in Aura Store) and then choose to update, also this mechanism get stuck at “installing…” after I choose “update”. (No matter what app it is).

So the update-mechanism is completly broken for me at the moment. Using a FP3 with the latest /e/-OS.

Anyone else has these problems?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone


this is a known issue that you can follow on our gitlab :

Aurora Store 3.2.9 updates Apps just fine on my Fairphone 3 with /e/ build IMG-e-0.10-p-2020080666687-dev-FP3.

1 Like

Yepp, Aurora is the better choice.

Yeah, but it seems broken, too, for @mcdaniels.

I have uninstalled the /e/ Apps installer for the current user via ADB, though, that’s a difference in our setups.

Are you trying to update system apos like MicroG?

1 Like

System apps or default apps that come with /e/ cannot be updated individually by user or manually by downloading the newer version. They can only be upgraded when a newer version of the ROM comes. The reason behind this is that newer version first need to be tested if they are compatible on the /e/OS. We have had issues with upgrades crashing the OS in the past.


thank you very much for your replies. I finally managed to get it working via Aurora after deleting the userdata which was stored with Aurora. I updated one app, then the next… and so on…

@AnotherElk Do you think that uninstalling the /e/ Apps installer will help additionally? May there be a conflict between the Appsinstaller and Aurora?

@Anonyme: I am aware that this issue is not solved yet, but I had another issue too.

@harvey186: Yes I tried this too (beside of Signal, Outlook app…) and noticed that system-apps cant be updated as @Manoj is telling us.

At the moment it is working via Aurora. Seems like you have to delete the “programdata” of Aurora from time to time?

I don’t really know whether it would help avoiding trouble. I just didn’t want to use it anymore, so I uninstalled it.

Conceptually I think it’s not the best idea to let two different updaters handle the same Apps, and apart from /e/'s Apps installer there are updates for the system Apps delivered via OS updates, and Aurora Store is aware of those system Apps, too.
To avoid possible conflicts, Aurora Store’s settings have an ignore list, in which you should enable every App you didn’t install via Aurora Store (yes, I know these are many).

I did no such thing up until now.