Update screen for 0.18 incorrectly says 0.17

I have a /e/ Samsung S9+. I have a new /e/ OS update available, version 0.18. When I touch INSTALL it brings up a confirmation dialog that says “You are about to upgrade to /e/ OS 0.17”.

Have you tried to go through with the update? I’ve had the same issue since 0.14 or 0.15. When I try to proceed I get an error and the update is not installed. I can install it from TWRP though, so that’s the workaround I’ve been using recently.

This is a known issue and has been reported for some devices:

Please can you add comments to that issue giving details of your devices. the more devices that are known to be affected, the better chance there is of it being fixed sometime :slight_smile:

That’s a different issue than I am seeing. The update worked as expected for me, the problem is the dialog shows the wrong version number.

Yes, and it worked for me despite the incorrect version number in the dialog (I didn’t need to use TWRP). I am now running 0.18.