Updated Corona Contact Tracing Germany from Apps fails

Today, my Apps store reported an update of the Corona Contact Tracing Germany app (which had been running successfully in version (installed via Apps) on my FairPhone2 with /e/ 0.13-2020120889008 and native microG). After the update, the CCTG app announces that it now needs at least version 0.2.16 of microG and refers to the microG F-Droid repository.

  • Can I safely update microG to the one from the microG repo without breaking any other apps? (Well, I know that no one might want to confirm this; but maybe you know some reasons against the update.)
  • Will I be able to update /e/ later on (when a new release is available) and revert to native microG – again without breaking stuff?
  • Will I lose my CCTG history in the process of any of these two updates?

I’d consider potential loss of CCTG history (if any; caused by incompatibility with the OS) a clear indication against making the CCTG update available in the official Apps store.


1 Like

Hi Ingolf,

the issue you describe has been raised both with the /e/- as well as the CCTG-developers. Unfortunately, there is no simple way (at least I wouldn’t know one) to update MicroG in /e/. You can even attempt an update via the repo. You probably won’t break anything - it wil just result in an error message.

I think even the normal Corona Warn App is affected if updated to the current version, as it relies on an updated Exposure Notification framework. At this point the best thing to do is probably to wait for the next update, which is scheduled for January (dev-channel). If anyone has a better solution I would be happy to hear it!

Presumably, the Framework should just continue to gather IDs. It is just the call to process them and calculate a risk level that fails. So, once microG is updated via system update, you should be able to once again assess your risk level with all the IDs you collected in the meantime.

I don’t expect this issue to crop up with every microG update in the future. I think the CCTG team is going to fall back on their own EN library, in case microG isn’t up to date in future versions (at least this is what they said in their-issue tracker). Also, the situation probably results from a Google and Apple update to Exposure Notification 2.0 and those updates don’t happen that often.

Sorry for many ifs and maybes. This is the way I understand what is happening and it may be really quite wrong :slight_smile: .


Is this the same issue reported here

Yes, I think it is.

I was able to open my app today by clicking on a notification that reminded me to check my risk status from time to time.
The app didn’t show the blocking update dialog then.

It said, logging was permanently active, so it continued to collect keys when I couldn’t open the app. But it did not compute a risk status for me. (basically what @DarthDavester explained in his previous post)

@Manoj Technically, yes. #2316 is the same issue.

However, in my opinion, there is an additional aspect: the issue in the bug tracker refers to an application installed from a non-native store (F-Droid). You could claim that in the case of non-native stores, it is the users’ task to check that all prerequisites are fulfilled before updating an application.

In my case, however, it was the native Apps store which lead to an incompatible update. Ideally, there’d be a mechanism which allows for inhibiting inclusion of incompatible updates in the store. For sure, you cannot always check compatibility for each of the apps, but regarding the CCTG app, the incompatibility had apparently already been spotted a while before its inclusion in Apps.


1 Like

I found a workaround here: https://codeberg.org/corona-contact-tracing-germany/cwa-android/issues/51

vanitasvitae proposes to downgrade to v1.7.1.2 (which is not possible from F-Droid, at least under Q) but it works with the following command:

adb install -r -d ~/Downloads/de.corona.tracing_1070102.apk

I can confirm, this worked on my FP3. While crashing when I first tryed to open it and taking some time to do a new check, by now everything is working.

Some more detailed instructions:

  1. Get the build of the CCTG app, download to the download folder, as indicated in the adb command above (or just change the link in the adb command) you can find the apk here (open link in browser): https://f-droid.org/de/packages/de.corona.tracing/
  2. Connect your phone to a computer that has platform tools installed.
  3. Confirm the phone is connected and authorised by allowing adb debugging in developers option and using this command:

adb devices

  1. If the phone is connected properly, enter the command mentioned above.

Now CCTG should be downgraded with the data partition intact. Don’t forget to disable automatic updates in whatever app store you are using for CCTG.

Really don’t know if there are any dangers to doing this, so everything at your own risk.

1 Like

Good news:

The latest release of the CCTG app ( has a fix for the problem. According to the ChangeLog:

Fix microG version check on /e/ ROMs (/e/ has two possible microG versions, one with ENF and one without. The one without ENF will now be correctly ignored.)

I updated the app via F-Droid and can now confirm that

  1. The app starts normally without reporting insufficient support in microG AND
  2. Gathering IDs apparently did continue also while running the incompatible version (as correctly presumed by @DarthDavester).

Problem solved for me. Thanks to all for this quick solution!


I tried to fix the problem by installing the microG version with ENF from the Apps Store :see_no_evil:. So this fix doesn’t work for me now.
Any ideas how I can go back to microG without ENF?
I see no uninstall button.

In this case downgrading CCTG via ADB seems the only option at this point.