Updates on upcoming builds

If you are in a hurry and can’t wait, then you can manually remove the installed version and install the latest Microg version in its repository (https://microg.org/fdroid/repo) via Fdroid.

(How remove microG of /e/ os?)

Is there an issue with this update or why are OTA-servers shut-down?

1 Like

Hi all!
I have a refurbished galaxy S7 preinstalled. I made an upgrade to /e/OS 0.11-2020082870470 - Android 8.1.0 via TWRP (e-0.11-o-2020082870470-dev-herolte.zip).
Since then, I saw that there was a OTA available = /e/OS 0.12-2020093076269 (789Mo). But if I click on install, it reads “you are about to install /e/OS 0.11 - 30 sept 2020” (OTA downloaded is 0.12).
If I click ok, I get an installation error message.
Does it come from my device or from the last update problems?

Dear all,

I have made the automatic update on my FP3 when I received the notification.

However, after the restart, I got the normal fairphone screen loading and then black screen message with “recovery” written and also “Can’t load Android system. You continue to get this message factory data reset and erase a device”

Do you have any advices for me?

Do I really have to reinstall everything?

Thank you for your help

You might try to change the slot from which you are booting … From which version to did you try to update? (Assuming also that you trying currently to update to 0.12-20201029… right?)


Thank you for your message.

Right, I tried to install the last update based on the automatic notification I received on my FP3.

I must admit it was a bit painfull for me to install /e/ on my FP3 at the begining an now I am a bit lost with the suggested procedure to change the booting slot. Is there a tutorial or something likewise?


I think in the post it is described rather clearly. First, connect your device to your PC and start a command window. If you have fastboot/adb installed it is just the two commands that are mentionned in the post, hopefully!
Assuming you have Windows
fastboot getvar current-slot
depending on the answer set it to the other one with:
fastboot --set-active=a or fastboot --set-active=b respectively.
Is that instructional enough for you to follow or is something still unclear?

1 Like

Thank you for your help and sorry for being “slow in understanding”, I don’t have competencies in doing such things…
I have started the FP3 in fastboot mode and then open a command prompt.

However, when I type fastboot getvar current-slot, I have the following answer: < waiting for any device >

In the mean time on the FP3 it is written in red that the “Device state” is locked. so I guess this might be related?


Ok your on the right way, I forgot to mention your phone has to be in fastboot mode but you did that anyway :slight_smile:
Your device being locked is not standing in the way of changing the slot! It seems to me that your Computer does not recognize your phone somehow you could try the following to list all connected devices and to see whether your computer knows the phone is connected:
fastboot devices
and additionally:
adb devices

1 Like

…in addition to that useful hints from BigFarb: if you use Windows, you have to install the appropriate USB drivers first. From Linux it should work out of the box.

If you tried to boot from both slots about three times and always get this error someone else has to help you as I am also not really advanced in these issues … at all :smiley:
Apparantly, it sometimes helps to try booting from the same slot several times but that is the last thing that I know could work

1 Like

Sorry, I wrote it too quickly.

Now it restarted!

Thank you very much for your patience and help!

Just one last question, what about the current slot A? how to remove the corrupted file?




No need to remove manually - it will be overwritten with the next (hopefully functional) update…


Ok, I guess I will now look on the forum before installing an update!

1 Like

you’ll better do … :wink:

Which version are you at right now @PierryvesPadey ? So “before” the update

Now I have: 0.11-2020082870302

You had to try multiple times? This is important info for others, they sometimes stop after one try, what i totally understand :slight_smile:

Currently there are three different versions of the 0.12 build at:
I do not know which one is suggested if you look for updates on your phone, so OTA, but this morning I succesfully updated from 0.12-20200930… to the newest 0.12-20201029… an it worked perfectly smooth.

Yes, I had to try 2 or 3 times and then it worked, I don’t know why obviously!

1 Like