Updating apps seems broken

When I tap ‘Updates’ in the App Lounge (where did Apps go?) says “Timeout fetching applications! Some network issue is preventing fetching all applications. Open settings to look for Open source apps or PWAs only”.

What are PWAs?

I’ve chosen ‘Show only open-source apps’ in the settings. Now the error message is: “Timeout fetching applications! Some network issue is preventing fetching all applications.”

Might this be a result of a broken system update? I still have the following unfixed:

I experience a somewhat similiar problem.
AppLoung trys to update some apps which get stuck on the install step and show something like retry on the update button which still didnt work after multiple retrys.

Hi. I don’t know if this could help you, maybe you have already try to… clear app cache?

Do you mean the cache of applounge ??
Then yes i tried that.

Today’s Week 29, 2022: Development and Testing Updates mentions assorted App Lounge defects which hope to be fixed in v1.2 as described https://gitlab.e.foundation/groups/e/-/milestones/81#tab-issues. Reported as

Status: :green_circle: Testing

1 Like

I may have managed to update some apps. But I still have selected ‘Show only open-source apps’. What are PWAs?

Website as app basically

Hmmm, this is not related to Stuck at system updates - #7 by u718096, because that is solved now, but I still face the situation described above.

@winkman: Thanks for the clarification!


I followed the link from u718096 and I cleared the cache and the storage from the updater. I tried to do the updates but I’ve still got this message: “Timeout fetching applications! Some network issue is preventing fetching all applications.”. I’m using the e/os 1.2 stable version and I’ve got the Fairphone 4 device. So, is it a bug from e/os ?


The link you mention is the System updater. For App Lounge you might try to follow

settings> apps&notifications> see all xxx apps> 3 dots on top right> App Lounge> storage & cache> clear storage

This link shows things fixed for 1.2 /e/OS v1.2-beta · e · GitLab I have found AppLounge slicker in 1.2, but maybe you have “debris left behind” maybe fixed with clear storage?


I tried your tip but I got the message (only once) telling me that the apps were updated. Otherwise, I always have the error message indicated by u718096. I can tell you that I’m on e/os 1.2 stable version and the issue is still there. :frowning:

I have also noticed that App Lounge requires a particularly clear line or else the error

“Timeout fetching applications! Some network issue is preventing fetching all applications. Open settings to look for Open source apps or PWAs only”.

I always have advanced privacy off, you might need to avoid using any vpn (including any vpn used by a network provider. Interesting I saw it once when battery state was quite low.


I disabled advanced privacy to see if it is solved the issue but no it is still there. I think the bug is still present. :frowning:
On my device, App lounge doesn’t work very well. Sometimes it tell me updates are done but I always the error message displayed. Sometimes App lounge tell me I’m not connected to the internet despite I activated mobile data.

Yes, this has been noted elsewhere, too.

Same issues here: fresh /e/@OnePlus 6 (1.1-20220628) install, Anonymous access - tried without success:

  • deleting cache and clear storage
  • tried different Wi-Fi both without any firewall magic, 1 with ip4 only, 1 with ip6+ip4
  • reboot

F-Droid store works without any limitation - as fdroid (+aurora) is my favorite app store, App Lounge failure isn’t a big issue for me.

I’m sort of having this issue. I cloned App Lounge to my work profile under Shelter, as described for how to limit the reach of apps you have privacy concerns about. In my normal profile, App Lounge works fine. Under Shelter, any attempt to view app updates results in this popup, and any attempt to download an app fails.

Interesting. I also cloned AppLounge to Work profile under Shelter, without problems (knocks wood). I downloaded a total (0/10 privacy score) tracker-fest travel app to my Work profile using the cloned AppLounge without issue. BUT, you need to have a clone of a web browser there, too, for the travel app, because it logs you in via a web page, then transfers back to the app.