Updating /e/OS on Fairphone 2 doesn't recognize mirosd card on restart

Hi all!

Before opening an issue at GitLab I’d like to ask the Forum if anyone shares my experience.

Problem: Since Android 9 (Pie) on Fairphone 2 /e/OS Update-process won’t recognize microsd card on restart. If then you restart FP2 manually it crashes and won’t react any more. You have to remove the battery and then again the phone will start and the microsd card is recognized.

Can anyone confirm this behavior or knows a solution?

Thanks in advance and happy easter (as happy as it can get right now)!

I don’t have this problem on my FP2. Perhaps you have a faulty SD card? Try to change it and let us know.

I also never ever had this problem (well thinking about it I had an SD card some time ago which was occasionally not recognized at all so I finally changed to another card. But this was not related to pie).
Do you use the SD card as internal or external memory?
There’s no need for removing the battery if FP doesn’t react anymore. Just press on/off button for 15 seconds.

Thanks for the quick reply!

I use the card as internal memory. I’d like to format the card but since all files will be deleted I need to move them to the devices storage. I just don’t know how. That might help with the recognizing problem.

I’ll try the 15 seconds trick next time.

I’ve read lots of user reports where this lead to problems (maybe sometimes caused by faulty SD cards). So often I found the recommendation not to use SD card as internal memory.
I think at least in current Android versions this function has even be removed.

Don’t know if that’s possible.
But if your data still fits on your internal device storage then it might be possible to do a TWRP backup (while also copying /data/media content to a safe place!), changing the configuration (to no longer using SD as internal) and restore data partition using TWRP (sorry, just an idea; I’ve never tried it).


Thanks for the tip with better not using an external card as internal storage. I did as you recommended and afterwards installing the latest update the above mentioned problem disappeared. Also restarting the device worked fine.

I guess, using the external sd card as internal storage (which by the way is still an option in Android Pie /e/OS) was the reason for this issue.

I recommend to all others (at least on the FP2) to NOT use the external sd card as internal storage to raise the capacity of the devices storage.


Thanks, that is a good tip. I did it in the beginning, but then I switched back to use my sd-card as normal storage. I am happy with it.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.