Updating Google Play Services?

Since a few days I run /e/ on a Redmi Note 5 (latest version). For now, I installed F-Droid and Yalp stores to access apps I like/need.
Today asked Yalp to search for Apps that need to be updated. Among the apps that Yalp proposed to update were Google Play Services (Version -> 15.0.90).
Just for curiosity I tried to update them but it did not work (luckily). Nevertheless, it would be good that this update proposal even did not happen in the future to avoid any kind of confusion.

I think that’s ralated to microG because “internal” microG is working as “GooglePlayServices”

Hi @ralxx as you may be aware Fdroid or Yalp are not a part of /e/ ROM. Since we install them separately their behavior is not controlled by the /e/ OS. FDroid will run its own set up checks. If you update the /e/ system app through FDroid they may not work or other apps will crash. This issue will be resolved when we release the /e/ application repository which will be integrated with the /e/ ROM. Do not have a timeline as yet for the /e/ App repository but it under development and testing phase at present.