Upgrade and installation issues putting e-0.16 on a OnePlus 7 Pro

Hi everyone,

I lately tried to upgrade my OnePlus 7 Pro, a GM1913 model from e-0.13 (probably, not completely sure which version it was) to latest e-0.16 (e-0.16-q-20210424112062-dev-guacamole). The upgrade procedure went through quite nicely (dirty flashed), unfortunately upon having booted, it had reoccuring issues, like the SIM card often not being recognized, the clock app hanging upon setting an alarm, wireless would immediately deactivate, reboots after app hangs.
Following I installed e-0.16 again, wiped dalvik afterwards, which then made the phone upon rebooting being stuck in the boot animation.
It has been quite a while since I had a phone in that situation and after having quite a few more attempts to flash it to e-0.16, I am still where I was before. I also flashed another OnePlus 7 (non-Pro) with the same procedure, that worked fine. The checksums for the downloads are also ok. An install with a factory reset before also did not help.

As I am out of ideas right now what the best way to proceed is, I would appreciate guidance here on how to proceed now.

Thanks in advance!

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

You mention dalvik so I guess you’re using twrp; is it installed on your phone?
Maybe first you could try booting recovery on the phone from being powered off, then factory reset, boot system.
When you installed did you format data before sideloading?

Hi Chris,

thanks for your answer.

My standard procedure is to temporarily boot twrp and then sideload the OS zip onto the device:

fastboot boot twrp-3.x-guacamole.img
adb shell twrp sideload
adb sideload e-os-0.16-x.zip
[optional dalvik wipe now]

That is what I did here as well. Which twrp works fine is usually a gamble on my op7p. On the last e.os version it was twrp-3.3.1-79-guacamole-unified-Pie-mauronofrio.img, now both twrp-3.4.0-10-guacamole-unified-Q-mauronofrio.img and twrp-3.5.2_9-0-guacamole.img work. Permanently installing them by temporarily booting twrp and then installing the twrp from zip does not work out, as twrp upon being started fails to detect the encryption. The decryption prompt is never shown, encrypted partitions remain inaccessible. As for the e.os recovery, I have not yet used that to install e.os.

I did not do a format so far, as I wanted to keep my user data. As I have saved that now, I might as well.

So I cold boot into recovery now (doing a vol-down to get into the bootloader and from there start into recovery. Is there a more direct way?). Then do a standard factory reset (using twrp or e.os recovery?) and boot right into the system again? I will give that a go in a few min.


It’s a bit of a longshot but worth trying first I think. Yes, boot recovery with button press. That should be e-recovery.

If that doesn’t work I would suggest the official instructions way of installing. Boot into e-recovery, factory reset/format data, sideload rom.

Ignore that, been pressing too many buttons lately:

(doing a vol-down to get into the bootloader and from there start into recovery. Is there a more direct way?)

Vol-down does of course go into recovery right away.

I now did a factory reset using e.os recovery, which also formatted user data. This unstuck the boot animation and e is starting up as it should. Very nice - many thanks! The app hangs and crashes are also gone.

Only the SIM remains not being recognized. The phone sees that the SIM is in its SIM slot, but it goes into “mobile network not available” right away without asking for the SIM pin. Changing mobile settings like disabling automatic network selection makes the settings app hang. I had one boot were the SIM PIN was asked for, but further mobile operations (network detection) seemed to be unreliable, so I rebooted and have not seen the SIM PIN prompt again since.

I guess the SIM card issue is the same as others reported here and would be best suited in a separate thread.

Chris, many thanks for the pointer to fully factory reset. I guess I would have given it a couple more shots without it, so thanks a lot for the timesaver and help!


You’re welcome Olli. Good luck with the SIM issue!